Need help? Check out our Support site, then


My widgets sidebar moved from the right side to the bottom of my page.

  1. Hi! Abruptly, my widgets sidebar has relocated itself from the right side of my page to the bottom. How unattractive! I'm not so sure why ...my site address is http://www.whimsingtongardens.wordpress.com. If someone could advise me, I'd be very grateful. Thanks.

    The blog I need help with is whimsingtongardens.wordpress.com.

  2. Sidebars and widgets in them do not fall to the bottom and display below posts and/or posts do not appear in sidebars unless

    (1) content has been imported into the blog

    (2) the blogger has been copying and pasting content from elsewhere, without using either icon 5 or icon 6 in Row 2 of the visual editor http://en.support.wordpress.com/visual-editor/#pasting-text

    (3) or the blogger has copied and pasted invalid HTML into a text widget or left an HTML tag open

    Go here and enable this > Settings > Writing
    Formatting
    _ WordPress should correct invalidly nested XHTML automatically
    "save changes"

    See here for sorting this out > http://wpbtips.wordpress.com/2012/05/19/sidebar-at-the-bottom-and-related-issues/

  3. Thanks for your reply! It seems I have an extra div tag...I'm relatively html ignorant. Do you spot the extra tag in the html code below?
    <div style="width:600px;margin:0 auto;">
    <div style="position:relative;"><img title="If I Were the Marrying Kind" alt="If I Were the Marrying Kind" src="http://cfc.polyvoreimg.com/cgi/img-set/.sig/d7GnkQhfIQM4Q081wl6kA/cid/86710274/id/4Rc0Up_7SFCPH1X_9E9umg/size/c600x670.jpg" width="600" height="670" border="0" /></div>
    </div>
    <div style="text-align:center;">

    IF I were the marrying kind, what a lovely and whimsical wedding gown this would make for a fairy themed garden ceremony! Don't you think?

  4. My sidebar is not showing up on my blog. I tried all kind of recommandation with no result. http://www.chefdoru.com

  5. @kpgantt: If that's the whole content of the widget, you don't have an extra tag, you have a missing tag. With very few exceptions, HTML tags come in pairs: an opening one and a corresponding closing one. You need to add this after the end of the text:
    </div>

    @chefdoru: See this post of mine, section B:
    http://wpbtips.wordpress.com/2012/05/19/sidebar-at-the-bottom-and-related-issues/

  6. I've tried that for all my 154 post with no changes. Any other ideas?

  7. Check your widgets as well.

  8. a) The problem is in this post:
    http://chefdoru.com/2013/06/26/dinner-at-the-trailer-2/
    The code of the fourth image is messed up. You need to delete the image and re-insert it.

    b) Your blog takes extremely long to load, because you've got too many images per page, and the images are huge. If you have a slow connection or a connection problem, the browser may time out before loading all the sidebar items (which again are too many).
    You should set a very low number of posts per page in Settings > Reading and/or use the read-more tag to truncate the posts.
    http://en.support.wordpress.com/splitting-content/more-tag/
    For future posts, at least, you should avoid uploading huge files straight out of your digital camera: loading time apart, you waste your storage space and you get worse image quality. Ideally you should use an image editing application or an online tool to downsize the images before uploading them.
    To tell you what the appropriate size is, I need to know something else: your images link to attachment pages when clicked; is that intentional or not?
    If you're not aware of the available options, see this post of mine:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

  9. Thanks a lot HTML GURU! How did you find out what and where was my problem? Actually I think it's a stupid question coming from a "novice" in computers languages.
    regarding the other pertinent suggestions, I followed your advise only for the first one and changed the posts per page from 10 to 1. The other advises......I will have to pass (no offence). I'm very proud of my pictures and I think they look gorgeous when blown up full size (at least this is my opinion) and even more proud of my widgets especially of my awards. The images are supposed to opened as a new page so people can see full size and details if they want.
    Anyway I really thank you for your profesional help in solving my problem. Can you tell me why this happened? I did something wrong? I would like to know so I won't repeat the same mistake.

  10. You're welcome.

    "How did you find out what and where was my problem?"
    Since the problem affected only the main page and the June archive page, it had to be in one of your June posts. So I visited each one of these posts to see which one produced a layout error. Once I located the culprit post, I checked its sourcecode and searched for the specific HTML errors that can cause such issues. In this case you could also tell by looking at the post itself, because the frame of the messed-up captioned image looked different.

    "Can you tell me why this happened? I did something wrong?"
    You probably tampered with the captioned image in the Visual editor. After inserting a captioned image you must make sure the cursor is outside the caption area before doing anything else, and you cannot use any of the tools of the Visual editor to change something that includes the image or its caption.

    "I'm [...] even more proud of my widgets especially of my awards."
    Of course. When I said they are too many, I meant they contribute to the loading time issue, but notice I didn't tell you to do anything about them: what I recommended had to do with the posts only. (Actually the sidebar can also be improved, but not much.)

    "I will have to pass (no offence)."
    No offense, but you're wrong!
    Images downsized by WP lose some color and sharpness - see here:
    http://wpbtips.wordpress.com/2010/01/16/image-quality/
    So you don't get best quality and detail when you upload a very large image, you get them when you upload an image that isn't wider than the displayed version. The images you upload are 3072px wide. The attachment pages you view when clicking on the images display the images at 848px. Each 3072px original is 3MB, while a 848px original would be around 330KB: that's one tenth the size. Do you realize what a difference this would make in terms of loading time and storage space? For largest possible on att. pages, best quality, and no waste of loading time and storage space, the ideal would be to downsize copies of your images to 848px wide, and upload/insert these copies instead of the huge originals.

  11. Hi JustPi -
    I am having the same issue with my sidebar being pushed to the footer at my site, http://www.pray4rameshrichard.wordpress.org

    I have read this: http://wpbtips.wordpress.com/2012/05/19/sidebar-at-the-bottom-and-related-issues/

    And I have followed the directions (checking the box in settings/writing and looking for stray div>. So far, neither has helped.

    I only have one post and when I look at just it, the sidebar is where it should be. When I look at the home page, it is below.

    I know that means it is probably one of my widgets, but they all are ones within the theme, not ones I imported - and I have no idea how to look at the code for those!

    Can you help? Thanks so much!

  12. Whoops - that should be pray4rameshrichard.com - not .org

  13. No, it's not any of your widgets. This could only be the case if you had added a text widget with wrong coding in it. The widgets that produce their own content automatically cannot create layout issues.
    The problem is a small malfunction of the theme when you're using the "concise" layout but have published one post only. Notice the heading "Previous Articles"? The theme expects to find and display older posts (as excerpts, in two columns), but you have no other posts yet, and the layout gets messed up. Go to Appearance > Theme Options and select the "detail" layout. If you prefer the concise layout, you can switch back to it after you publish at least two more posts.

  14. Wonderful! It worked perfectly. Thanks so much for your help. I absolutely never would have figured that out. :)

  15. You're welcome.
    (Yes, no normal user would be able to figure this out: I had to examine the code of the page to find where the mistake was, then experiment in my tests blog to find when and why it was produced.)

Topic Closed

This topic has been closed to new replies.

About this Topic