Need help? Check out our Support site, then


nav bar still shows page i trashed

  1. I am using the Bueno theme. I deleted my Home page but it is still showing up in the stop navigation menu (I do not use a side menu). Why???

    The blog I need help with is miscegenations.wordpress.com.

  2. Argh. I mean to say "top navigation menu," meaning the one that runs horizontally beneath the header.

  3. i have spent the few hours reading everything i could find on this. i understand that i need to direct another page to my front (home) page so that i do not have two duplicate pages. but the complication is that when i go to manage pages or when i try to set a parent page, the page titled "home" does not show up.

    i'm not sure how to direct my "about" page to my "home " page if i cannot find it as an option.

    my site: http://miscegenations.wordpress.com

  4. You seem to be somewhat confused about all these issues. But your blog is set to private; if you want us to untangle this, you'll have to temporarily switch to the middle privacy option so we can check things. (Or wait for a staff reply, which might take long.)

  5. please pardon my confusion. i'm (obviously) just figuring this out.

    the site is now public. http://miscegenations.wordpress.com

    in a nutshell: i have two pages pointing at the same place. the "home" (front) page and the "about" page. just want to point the "about" page to the "home" (front) page so the "about" no longer shows up in the nav bar.

    i have read the forums about having two home pages. i tried making another one and deleting it, but that did not work. i have also made it so that posts no longer go to the "home" page.

    many thanks for all assistance!

  6. Sorry, the site is still private. To make it accessible to others, you need to go to Settings>Privacy, select the middle option, click Save Changes.

    But I'll try to help without seeing your blog. I understand you've gone to Settings>Reading and set your front to display your About page. There are two ways to remove the About tab from the top nav menu:

    a) In Appearance>Menus you can create a custom top nav menu comprising only the items you want. Add a new menu, give it a name (e.g. "My Menu"), select pages, click Add to Menu, click Save Menu, select "My Menu" from the dropdown in the Theme Locations module, click Save.

    b) The standard menu of the theme displays parent pages only, so you can hide a page tab by turning the page into a child page (provided you have published other pages as well): edit the About page, select one of the other pages as its parent (in the Attributes module of the page editor), click Update. To display the standard menu, make sure the blank option is selected in the Theme Locations dropdown in Appearance>Menus.

  7. thank you so much for your assistance on this. now the blog really is public.

    i made a custom menu and made it the primary menu. i only included the four pages i have made, but the "home" page tab is still showing. again, fine if it shows, i'd be happy to just put the "about" information on the "home," i just don't understand how to do that.

    the second option i can't figure out, because the "home" page does not show as an option in the pull-down parent menu. in an ideal world, i would just do this and make the "about" page a child of the "home" page. surely there must be a way to point the "about" page to the "home" page?

  8. Some themes have front page "Home" tabs (aka Blog, etc.). These are just tabs and they cannot be edited. They are supplied by the underlying template and we cannot edit templates. If you have you two Home links, you can hide one of the pages. http://support.wordpress.com/pages/hide-pages/

    Some themes have the custom menu feature and others don't as yet.
    Provided that you change to a theme that does have the custom menus feature you can achieve what you want to do.

    Have you ever wanted to have a different title for one of your pages than the label displayed in your site’s navigation?
    Ever wanted to change the order of the list of pages to an order you chose yourself?
    Ever wanted to be able to mix pages, categories, and random links in your navigation instead of your theme deciding for you?
    If you answered yes to any of these questions, you’re in luck! The new custom menus feature will do all those things.

    The themes that have this feature are listed here along with instructions for setting up a custom menu. Currently, the following themes have this feature enabled: Twenty Ten, Structure, Vostok, Bueno, Enterprise, Notepad, Paperpunch, MistyLook, Under the Influence, Vigilance, Greyzed, Wu Wei, Blix, Freshy, Contempt, Ambiru, Digg3, Koi, Modularity Lite, Coraline, Oulipo, Ocean Mist, Tarski, Rounded, Albeo, Regulus, Andrea, Inuit Types, K2 Lite, iNove, and Fusion. http://en.support.wordpress.com/menus/

  9. Thanks, Time Thief.

    I don't have two home tabs, I have two tabs pointing to the same place, the "about" and "home." I would like to be able to hide one of them. I don't mind having the built-in "home" tab, I just don't need for both my "home" and "about" tab to do the same thing. What I would like to do is point my "about" tab to the
    "home" and just hide the "about" tab.

    I tried the custom menu but the same problem exists. I cannot find a way to link any of my pages to the "home" tab. Is there a way to do this? How can I control what people see when they click "home"?

    My site is http://miscegenations.wordpress.com
    and I would be incredibly grateful if someone would take a look at it.

  10. @melismo, what you need to do is to create a custom menu and then include only the items you want in the new custom menu. If you want a "home" tab that points to your current main landing page (which you have set to your about page) then in the "pages" section in the custom menu page, click the "show all" button and then include the "home" tab. Select the other pages you want to appear in the menu, click add to menu, and then click save menu. Follow the support document that timethief referenced at the bottom of her reply right above yours.

  11. • There's no Home under Pages because Home isn't a static page such as those you can create: it's just a link to the blog front.

    • In Bueno you can also remove the Home tab by going to Appearance > Theme Options and unchecking the option "Show a link to your home page in the nav menu".

    • But since you've set your About page as your front, the About tab is useless. That's the tab you must eliminate, not the Home tab.

  12. Corrected! Thank you all so much for your assistance.

    Panaghiotisadam, I unchecked the option to "show a link to your home page in the nav menu" and it disappeared! Magic!

    Thank you all.

Topic Closed

This topic has been closed to new replies.

About this Topic