Need help? Check out our Support site, then


Need help setting a preferred domain with WordPress and Webmaster tools..

  1. Well, I've spent HOURS trying to figure this out!! HELP.. PLEASE!!

    Okay, my issue is this.. I have been using webmaster tools for a while; and don't have any problem with my other sites; but the one I have on WordPress I noticed a) my entry pages on my stattracker.com page always looked funny to me.. It would never register where the person came from; it would never come up in google search when I on my wordpress stat page; it would show clearly that a lot of people were finding my page from google search. That was my first flag something wasn't right..
    The second; and the big one that bothers me the most... On my webmaster page, it would show up all the pages that were indexed, it would show my search queries etc.. But information that I normally use on my other sites like links coming in, html suggestions, etc.. it says no information available.

    I am fairly certain that the reason my links aren't showing up and this information is because most all of my links were of the WWW. variety; whereas when someone goes to my page, or clicks on those links there is an automatic redirect to http://theglassmall.com I can't do anything about this either it seems; because when I went to the domain mapping section of wordpress.com; when I tried to add http://www.theglassmall.com it says that it has already be mapped.
    So left with only two options to choice from on my domain mapping; I thought maybe I needed to try to verify also the http://www.theglassmall.wordpress.com version with webmaster tools; then set the preferred to either theglassmall.com or http://www.theglassmall.com and that maybe it was that .wordpress.com subdomain that was causing the problem with my webmaster tools...

    But this isn't working either...
    According to all the posts and articles I read, they say to then add the different versions of your domain (www.domain.com; domain.com; domain.wordpress.com) verify them, then set the preferred domain after they are verified.

    Sounds good enough, makes sense to me..
    won't work though!

    I'll verify one, then proceed to switch over to theglassmall.wordpress.com (by switching the preferred domain in WordPress and then entering the google verify key in tools section). I'll verify it, but then when I get back to Google webmaster tools to try to click the option "set preferred domain" and click http://www.theglassmall.com It will say that the other is no longer verified (which I understand, I think, because when I switch over to the other subdomain, and change the webmaster verify key, it is basically erasing the verification on the other subdomain.. BLAH!

    Anyway, does ANYONE know what to do here? I've spent hours on this and it doesn't seem like anyone had a similar issue to mine. hmmmm
    Well I'd appreciate any help. Thanks! :D

    The blog I need help with is theglassmall.com.

  2. Hey there,

    WordPress.com redirects all www URLs to their non-WWW counterparts. For example, try visiting the following URL:
    http://www.wordpress.com

    We automatically map the "www" subdomain for your domain to your blog so that we can do this redirect. You don't need to worry about adding this mapping; just add the mapping for the no-www version and everything will be all set.

    We do not allow users to opt to utilize the "www" version of their URL at this time. As a result, you'll want to set your preferred domain in Google Webmaster Tools to the non-www variety of your domain, theglassmail.com. This will cause all of Google's traffic to be routed through the proper channel, which will make sure your statistics display properly.

    Please let me know if I can be of any further help.

    Best,
    P.

Topic Closed

This topic has been closed to new replies.

About this Topic