Need help? Check out our Support site, then


Need to remove particular html tag from all (300) posts.

  1. I noticed awhile back that if I have the img class="size-full in my caption code in html, the resulting picture hangs off the edge of the nice caption block that wordpress provides.

    If I remove the "size full" from this:

    [caption id="attachment_6781" align="alignnone" width="405" caption="Jack, incredulously watching us decorate the tree."]<a href="http://n999za.files.wordpress.com/2011/12/20111211-009-large.jpg"><img class="size-full wp-image-6781 " title="20111211 009 (Large)" src="http://n999za.files.wordpress.com/2011/12/20111211-009-large.jpg" alt="" width="405" height="303" /></a>[/caption]

    Then the picture fits nicely into the caption block.

    Bad pictures here: http://n999za.com/2011/11/08/checklist-and-POH/
    Good pictures here: http://n999za.com/2011/12/12/right-flap-brace-and-aileron-gap-fairing/

    Short of editing each post (I have about 300), then copying to word so I can use the find-replace on the code, is there a way to remove all of them from every post in one operation? I thought about exporting to xml, removing them all, the reimporting, but I'm nervous about the import.

    Any ideas?

    The blog I need help with is n999za.com.

  2. Maybe you ought to post into this thread where Staff is helping people who have image sizing issues > http://en.forums.wordpress.com/topic/wp-changed-format-of-my-pictures-why?replies=332

  3. Thanks timethief, I did just that.

    Thanks!

  4. Reason why this is happening:
    Selecting the full-size option means the image will be downsized to the width of the post column (450px in Contempt) if it's larger. But captioned images have that frame around them, plus images in contempt get some margin around them, so 450px-wide versions of the images run past the right end of the post column. What you should for future posts is go to Settings>Media, set the width for the Large option to around 420 and the height to 0 (so that it plays no role), and select Large instead of Full Size when inserting captioned images.

Topic Closed

This topic has been closed to new replies.

About this Topic