Need help? Check out our Support site, then


New gallery can you put in single photo without it going into gallery?

  1. I put 12 photos into new gallery lay out and loved how it looked. Did the post then wanted to put single photo at end of post. It went in ok but it also went into the gallery. Is there any way to stop it going into gallery.

    The blog I need help with is pommepal.wordpress.com.

  2. If you mean a Gallery like this: http://en.support.wordpress.com/images/gallery/ then you can use an "exclude" to keep the single photos out of the Gallery. You'll have to modify the Gallery shortcode to use the exclude and you can only do that in the Text tab in the Post Editor. Your shortcode would look like
    [gallery exclude="XXXX"] where XXXX is the image ID number of the photo you want to exclude. How to find the image ID number.

    If you mean a Slideshow like this http://en.support.wordpress.com/slideshows/ then you can delete the photo from the post where the Slideshow appears, then upload the photo to a different post that doesn't have a slideshow or gallery. After uploading the photo close the post where you uploaded the photo and go back and insert it in the post where you deleted it from.

    Hopefully clearer than mud. :)

  3. G'day Jenni

    Thank you for prompt reply. It is now another day and I am feeling wide awake!!!! So I am now going to do another post and see if I can work it out. Will report back as to how I get on....

    Regards Pauline (pommepal)

  4. Hi Here I am again, I cannot get to the first step as I do not know where the post editor is and how to find the text tab!!!
    I'm sure it will be very simple and it is just me....

  5. Well I'm struggling on, I have now found where the text tab is in the Post Editor, but now can't find the short code to change.....

  6. Sorry for the "late" reply. It is now morning where I am and I've just seen your post. Will only be on the board occasionally today, though.

    Would you like to give us the link to the post with the Gallery to make sure we are talking apples?

  7. Good Morning, thanks for getting back. It is Sunday over here (Australia) so did not expect to hear from you till tomorrow.
    Link to first post.. http://memoriesaremadeofthisblog.wordpress.com/2012/10/06/weekly-photo-challenge-happy
    Then today I have started to do a new post to try to put your advice into action, unfortunately I am having problems so have put it into the to hard basket for the time being...

  8. We forum volunteers don't keep office hours so much; We look in when we can. Since we're an international bunch, someone is usually online at some point during the day.

    In your post I assume it is the sunset photo you want to keep out of the Gallery, so in the Post Editor for that post, switch to the Text tab, look for the Gallery shortcode (pretty much at the top where you inserted the Gallery) and modify the Gallery shortcode like this:
    [gallery type="rectangle" exclude="320"]

    The 320 is the image ID number, which shows in the code for the inserted photo as "attachment wp-att-320".

  9. Thank you again, well I had fun working that out. Eventually I got the sunset out of the gallery, but ended up with 2 identical galleries!!!! So deleted one, but it was the top one I deleted and now seem to have an ID under the photo of me. Well I am ok with the end result but will try again with another post and see if I can refine it....

    Thanks again I love WordPress and appreciate all the help

  10. Oh dear, hope you are not getting too fed up with these dumb questions...
    I am now trying to do next post...http://memoriesaremadeofthisblog.wordpress.com/2012/10/07/weekly-photo-t…gallery-format
    Now unfortunately when I hover over the sunrise photo in the media library the caption does not open far enough for me to find the ID number. Is there any way to extend the length of the caption?

  11. http://memoriesaremadeofthisblog.wordpress.com/wp-admin/post.php?post=325&action=edit

    Seem to have given you the wrong address in the above note...

  12. As I explained above, the image ID number is gotten from the image insertion code or by looking in the Media Library. You won't find it in the photo's caption. Refer to the post I gave above. http://en.forums.wordpress.com/topic/new-gallery-can-you-put-in-single-photo-without-it-going-into-gallery?replies=11#post-1031891

    I have a feeling you may have copied my above gallery shortcode and pasted it in your Post Editor's Text tab, along with the shortcode that was already there. That's why you ended up with two galleries. Don't copy/paste. You have to modify the existing shortcode to exclude the single image.

    If you want all your Galleries to appear as mosaics, it may just be easier to set it as the default display. Here's what the Gallery support doc says

    To switch to tiled layouts from the default, head over to Settings → Media in your blog’s dashboard, scroll down to “Image Gallery Carousel,” and select the box next to “Display all your gallery pictures in a cool mosaic.” Note that choosing this option makes this layout the default for all your blog’s galleries, including those you’ve previously inserted.

    You'll still have to use excludes if you want a separate image to appear in your post that contains a Gallery, but following the instructions I gave you above, you should be able to find it.

  13. Thanks Jennifer, I have done all that and now understand how I got the 2 galleries, I do have the default for "cool mosaics" ticked. The only difficulty is when I hover over photo to look for ID in the photo status bar, (not the photo caption) the status bar does not open far enough for me to read the number. If I stop hovering the mouse over the photo to try to scroll the status bar, of course the status bar then disappears. Is there any way that the status bar can be extended?.... (sorry I see I called it "caption" in the above query)...

    I thank you for all your patience.

  14. Thank you Jennifer all worked out now

  15. Glad to be of help! Cheers and best wishes for your site!

  16. ou, for me is not working this, i put exclude and the name of the photo and it is still showing the photo into the gallery, could somebody help me?

  17. yes timethief, but this is not working, i put the name of the photo in the exclude, but is not working

  18. @zireja - it is not the name of the photo, but the image ID # that has to be entered in the exclude. See my reply here: http://en.forums.wordpress.com/topic/new-gallery-can-you-put-in-single-photo-without-it-going-into-gallery?replies=18#post-1031891

  19. ahhhh, okk! big tthankssss

Topic Closed

This topic has been closed to new replies.

About this Topic