Need help? Check out our Support site, then


No "add media" button in my posts

  1. I have no "add media" button in my posts and no "create gallery functionality in my media library. Can you help?

    The blog I need help with is wttresultsblog.wordpress.com.

  2. Are you logged in under the exact same username account that registered the blog who is the Admin of the blog and who "owns" the blog?

  3. Yes, I am logged in using the same username. Is there a way to double-check? Some of the posts suggest the browser is relevant. I am using Firefox 20.0.1

  4. Your browser is one of the browsers and version found here http://browsehappy.com but you could have another browser related issue.

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

  5. P.S. I see several threads where bloggers using Firefox 20 are experiencing the same issue so I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

  6. Thanks for swift response, I am subscribed. I had already done 1,2 and 3 above and have now done 4 also, but still have no "add media" button, so cannot add a gallery of images. BMR.

  7. Hopefully you understand that you create galleries in Posts and Pages http://en.support.wordpress.com/images/gallery/ and not in the Media Library where your media is stored.

  8. Yes, I do. I am using the "New Post" option near my Gravatar near the top right of the page, but stll I only have "add photo" in the post; no "add media" button still. Thanks for helping.

  9. I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

  10. Try it via Posts -> Add New in your blog's Dashboard instead.

  11. I'll be darned! I've now got an "add media" button to play with!! Thanks!

  12. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic