Need help? Check out our Support site, then


no chronological order

  1. Hello!

    I have all my posts sticky, so the excerpt and one pic show up on the first page and everything went fine until a few days ago.
    Once in a sudden the chronological order is mixed up.
    Everything works until February 2010. Then suddenly some 2009 post show up and then 2010 again. It was not like this until a few days ago.
    Something changed in the wordpress code?
    How can I get back my chronological order?

    (click my name to get to the page)

    thanks a lot!

    The blog I need help with is kiehas.wordpress.com.

  2. You've found one of the reasons never to set all of your posts to sticky posts: Eventually it turns the sky above your blog into a mushroom cloud.

    The sticky post feature was never mean to be applied to all of your posts for any reason. It was meant to allow you to showcase, or spotlight a post or two.

    Another problems with setting everything to sticky is that if forces all your posts onto the main page of the site and at some point you reach the limits of PHP/processor cycle time on the servers and your site from that point forward will not fully load and error out.

    Yet another problem is that search engines consider page loading time when calculating search engine ranking and the slower your site loads, the lower your page rank. I've even seen a few instances where the search engines will ignore very, very slow loading sites.

    You can (after you unstick all your posts) set a static front page for your site and then use the archives shortcode on that page to produce an ascending list of your posts on that static front page, or you can follow the procedure on this support page aimed at people writing an online book.

Topic Closed

This topic has been closed to new replies.

About this Topic