Need help? Check out our Support site, then


No comment box on my home page posts

  1. threepointeightbillionyears
    Member

    On my home page, my current post never shows the space for comments, or the sharing, liking, related posts, etc. But If I open the post (clicking on the title) it does. I've confirmed that visitors see the home page the same way. And I see that other blogs have the full comment and liking displays on their home page post. How can I set my home page to show the comment box and other displays for the current post automatically? (I use the Misty Lake theme.)

    The blog I need help with is threepointeightbillionyears.com.

  2. threepointeightbillionyears
    Member

    I forgot to mention that what does show at the bottom of each home page blog are, in tiny faint letters, the categories and tags, the words "leave a comment," and the word "edit."

  3. Hi there - All themes have the comment form on the single post page, not the front page. This is because (among other things) if you got a lot of comments, say 100, on a single post, that would make scrolling through them on your home page very difficult.

    Your theme has a "Leave a comment" link after each post on the home page.

    To put the sharing buttons on the home page, go to Settings->Sharing here: https://threepointeightbillionyears.wordpress.com/wp-admin/options-general.php?page=sharing

    There, check the "Front Page, Archive Pages, and Search Results" option for "show buttons on."

    Let me know if you have further questions!

  4. threepointeightbillionyears
    Member

    Okay. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • Started 9 months ago by threepointeightbillionyears
  • This topic has 4 posts
  • 2 posters
  • Latest reply from threepointeightbillionyears
  • This topic is not resolved
  • RSS feed for this topic

Tags

No tags yet.