Need help? Check out our Support site, then


No Featured Post in iTheme2

  1. I really want the Featured Posts in iTheme2. I add feature images and I made all my post 'sticky' So why isn't it coming up?????

    My blog: teachno101online.wordpress.com

    The blog I need help with is techno101online.wordpress.com.

  2. Hi, it looks like you have a "static page" selected to be displayed as your homepage. To have the featured images display in iTheme2, you will want to switch the home page back to display blog posts.

    To Fix, log in and navigate to Settings → Reading. Under the section titled "Front page displays" you will want to select "Your latest posts". Screenshot.

    Please let us know how this works for you!

  3. I did it but there is no post the is under the featured post bar. Would you do it?
    user:azahn4
    pass:iPad.0356

Topic Closed

This topic has been closed to new replies.

About this Topic