Need help? Check out our Support site, then


no home page in the pages

  1. I can't find the home page among the PAGES, although I have it in the menus, the system doesn't allow me to give another created page the URL of my blog
    Blog url: http://pdmonteverde.wordpress.com/

  2. The home page is the landing page - the first page anyone sees when they visit your blog. It's not a 'page' in the same way as other pages, unless you call one of your published pages 'home'.

    However, if you want your blog to look more like a website, you can do this:

    http://en.support.wordpress.com/pages/front-page/

    Also read about Custom Menus:

    http://en.support.wordpress.com/menus/

  3. The normal "home" page is not a static page like you create at pages > add new. It is a dynamic page that is created on the fly whenever a browser requests it. There is nothing to edit since it does not exist.

    Create the page you want to use as a front page and publish it. Then go to settings > reading and set that page as your static front page. The "home" page tab will automatically link to it correctly (unless you have created a custom menu in which case some editing of the menu will be required.

    http://en.support.wordpress.com/pages/front-page/

    If you also want a blog page to show your posts, create one of those as well and publish it and set that as your "posts" page at settings > reading.

  4. Thank you all very much, your effort has been useful.
    The template I'm using allows you to have two buttons that lead to pages "Home" and "About". Well, I was able to insert a header in the page "Home", in other words the page "Home" did exist in a first place, I just did something wrong I made it disappear.
    But with the option "display a static page" as suggested here http://en.support.wordpress.com/pages/front-page/ I was able to create another page named "Home" with the URL of the blog.

Topic Closed

This topic has been closed to new replies.

About this Topic