Need help? Check out our Support site, then


No special Facebook album created even when connected already via Publicize

  1. frantasticlife
    Member

    My blog is already connected to my Facebook account. When I publish a post, yes it is also automatically published to Facebook (the one with the link and the featured image) but no special Facebook album is created as mentioned in the new improved features of Publicize.

    The blog I need help with is frantasticlife.wordpress.com.

  2. no special Facebook album is created as mentioned in the new improved features of Publicize.

    http://en.blog.wordpress.com/2012/10/19/improved-publicize/
    I'm sorry I can't help you. I have flagged this thread for Staff attention.

  3. Please try reconnecting Publicize following this guide: http://en.support.wordpress.com/publicize/#reconnecting-facebook

  4. Also, for now the posts need to be published in either the Image or Gallery post formats in order for the images to be sent to a Facebook album.

    https://en.support.wordpress.com/posts/post-formats/

  5. frantasticlife
    Member

    Thanks! I hope in the future WordPress would send the images to a Facebook album regardless of the post format used. That would be nice since some great themes don't support post formats.

  6. We are actually working on that now. :)

  7. Guys ,

    Is this working for Jetpack Publicize?

    I've been publishing a gallery on my self hosted site and it is shared via the facebook connection but no album is created in Facebook.

    Note my connection is to a Facebook page rather than my personal account, could that be the problem?

    Note I have tried reconnecting to Facebook several times and so far the behaviour is the same (IE the link is shared but no album is created)...

Topic Closed

This topic has been closed to new replies.

About this Topic