Need help? Check out our Support site, then


nuking comment box on static page

  1. Hi,
    New guy here. I'm working on my first WordPress based website....never used this before, and am having a bit of trouble wrapping my head around this. First off, on my "home" page which is set to static, how do I get rid of the "Leave Comments" box at the bottom?
    Thanks in advance,
    BJ

    The blog I need help with is exetermusic.wordpress.com.

  2. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    We can also overide the default settings and enable or disable future comments on any post or page.

    Go to the top right hand corner of your Admin page and click "screen options" and enable the "Discussion" module there. http://en.support.wordpress.com/screen-options/

    Pages > disable and enable comments > http://en.support.wordpress.com/enable-disable-comments/#enabling-and-disabling-comments-using-the-discussion-module
    Edit page and under the editor box scroll down until you find the "Discussion Module"
    locate and disable these:
    Discussion
    __Allow comments.
    __Allow trackbacks and pingbacks on this page.
    Click "update"

    When we close comments a phrase like "comments closed" or a similar phrase will appear and it can only be removed by CSS editing after purchasing a custom design upgrade.

  3. panaghiotisadam
    Member

    In many themes there's no such phrase when you disable commenting, especially on static pages - see here:
    http://wpbtips.wordpress.com/2010/05/06/comments-off-2/

  4. Ta-da. That worked. Thanks very much.

Topic Closed

This topic has been closed to new replies.

About this Topic