Need help? Check out our Support site, then


Odd issue with Facebook button on social bookmarking buttons

  1. Hello,

    I have been having a strange problem with my Facebook button on my social bookmarking buttons. When I attempt to use the Facebook button to link a post from my blog to my Facebook page, it also ends up including on Facebook the text from the last tweet that I did on Twitter . I have tried two different methods for the buttons:

    -Raincoaster's code for the social bookmarking buttons
    -GetSocial (just used GetSocial for the first time today -- http://rodneysjobquest.wordpress.com/2009/10/26/the-winners/)

    I have no idea why this is happening. Or is this normal?

    My blog is http://rodneysjobquest.wordpress.com/

    Thanks for any advice you may have for me!

    Melissa

    The blog I need help with is rodneysjobquest.wordpress.com.

  2. Not normal at all, especially since you are using two different methods of using social bookmarks on two different posts and still getting the same results.

    Can you try this and see if that solves the problem? http://en.support.wordpress.com/settings/writing-settings/ Under Dashboard>Settings>Writing Settings>Formatting, check the "WordPress should correct invalidly nested XHTML automatically".

  3. I just made the change you suggested, and here's what happened when I posted them to Facebook:

    -Today's post (the only one using GetSocial) just shows "rodneysjobquest.wordpress.com". Nothing else -- not the title of the post, not the first few words of it, nothing. It does link to the correct post, though.

    -The post from last Friday (using Raincoaster's code) worked perfectly with the title of the post, the beginning phrases, etc.

    -The post from yesterday (also using Raincoaster's code) has my last tweet attached.

    Not quite sure why one of them worked and another didn't... May have to try Raincoaster's code again tomorrow to see what happens. It's easy enough to use. Though I like the look of the GetSocial buttons (I'm a sucker for shiny objects LOL)

    Thanks for the suggestion! We'll see what happens tomorrow and if yesterday's post was just a fluke.

  4. For the Get Social Matter I recommend contacting the widget author directly so they can become aware of this matter here is their contact link http://hillelstoler.com/contact/

  5. II.

    Might someone comment upon the web analyst Quantcast? They suggest adding a tag to each post in order to analyze visitor traffic. As far as you know is this both safe and effective? Here is the tag:

    <!-- Start Quantcast tag -->
    <script type="text/javascript">
    _qoptions={
    qacct:"p-05_DrYhoSlCWo"
    };
    </script>
    <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
    <noscript>
    <img src="http://pixel.quantserve.com/pixel/p-05_DrYhoSlCWo.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>
    <!-- End Quantcast tag -->

    Thank you

  6. It's javascript and is not allowed due to security concerns: http://en.support.wordpress.com/code/#javascript .

  7. @t3ck Good idea! Thanks for the link.

  8. Your welcome! mmcool1,

  9. @mmcool1 -I'm still seeing your last tweet along with the post title, so it doesn't seem like that setting change helped.

    //@4854derrida- rather than hijack a thread that really doesn't have anything to do with the OP's question, better to open your own thread. just sayin'...

  10. @justjennifer Thanks for letting me know. I just put up a new post a few minutes ago and tested the Facebook button to see what would happen. My last tweet showed up again despite that I have yarnaholic's suggestion in place.

    Any other thoughts/suggestions?

  11. I just tested the Facebook buttons out again, and they are working perfectly. Not sure why it didn't work before and why it works now, but I guess it's all OK... Thanks for the help people gave.

  12. Welcome, wish it were possible to fix all my problems by waiting. :)

  13. No kidding. With my luck, the issue will rear its head in a day or so, just to make me crazy ;)

  14. I thought I was just joking with my previous comment, but apparently not...

    I'm having the *same issue* with my FB buttons again. Doesn't matter if the button is through GetSocial or the code provided by Raincoaster -- they all have my last tweet attached when I try to post to FB.

    Is anyone else having this problem or am I doing something wrong? It's starting to be annoying that it works sometimes and other times it doesn't.

    If anyone can help, that would be really wonderful. My blog again is http://rodneysjobquest.wordpress.com.

    Thanks so much!

    Mellissa

  15. I'm still having issues with the FB button attaching my tweets. FWIW, here's the code for the button:

    \<img src="http://sunburntkamel.wordpress.com/files/2008/02/facebookcom.gif" alt="post to facebook" title="facebook:Are Illusions THAT Important?" />\

    Does anything look off? Any help would be appreciated.

    Melissa

  16. I'm relatively certain the problem is your Retweet This Post button which is just below the social bookmarking buttons. Can you space them out, maybe put your photocredit line between them? Anything? That might just do it, because there will be a P and /P break in between. Or can you change the order?

  17. @Raincoaster That's an idea I didn't consider. Changing the order wouldn't be a big deal at all. Or maybe it would work if I manually enter into the code a P and /P command without other text. I'll play around with that and see what happens.

  18. I'm suggesting it not because I'm a coding genius or anything, just that I've had some similar issues in the past. You might need to use div tags instead, and a line of text would be even better.

  19. @raincoaster Well, I gave it a shot on my post today. Didn't work. *sigh*

    Other thoughts???

Topic Closed

This topic has been closed to new replies.

About this Topic