Need help? Check out our Support site, then


Old Blog Picture Still Showing Up

  1. I recently changed my blog picture in the settings section of the dashboard. The blog picture looks different for most things, however, when I post a twitter link and sometimes when I post a link on facebook, the old blog picture still shows up. This is happening over a month after I first change the picture. How do I get the new blog picture to show up when I link to my blog?

    The blog I need help with is humblevision.wordpress.com.

  2. See here please:
    http://en.support.wordpress.com/avatars/blavatars/
    http://en.support.wordpress.com/avatars/gravatars/

    Note: Gravatar images are cached and frequently take several days to display after a change. The first place they tend to display is here in the forums. Don't keep uploading or the time for displaying will move forward. If several days have passed and that change is not in evidence then post here for Gravatar support > http://en.gravatar.com/site/contact-us/

  3. sometimes when I post a link on facebook, the old blog picture still shows up.

    Unfortunately, we have no control over the images that Facebook chooses to display or when they choose to flush their image caches. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include. From: http://en.forums.wordpress.com/topic/avalaible-facebook-thumbnail-issue?replies=7#post-1000734
    Read also: http://developers.facebook.com/tools/debug
    from: http://en.forums.wordpress.com/topic/fb-link-has-no-thumbnails?replies=4#post-936861

Topic Closed

This topic has been closed to new replies.

About this Topic