Need help? Check out our Support site, then


"Older Posts" button not working

  1. (I posted another version of this question about a week ago and got no replies; I'm hoping this description is clearer).

    My blog uses the Quintus theme and has infinite scroll turned off. On the home page, there are two buttons labelled "Older posts": one at the top, and one at the bottom. The one at the top works fine (if you click it, it will take you to /page/2 of the blog), but the one of the bottom fails on the https version of my blog.

    On the http version (http://unlikelyexplanations.com), clicking on this button will cause an animated spinning icon to display (the kind of thing that indicates that something is loading) and then append earlier posts to the same page. That's fine. On the https version (https://unlikelyexplanations.com), clicking on the bottom "Older Posts" button will cause the spinning icon to display and the button to disappear, but no additional posts will appear (i.e., after the icon stops spinning, the page looks exactly like it did before the button was clicked, except that the button is gone).

    I've seen the same behavior on Firefox 20.0, Chrome 26.0.1410.65, and Safari 6.0.4. Before testing, I cleared cache and cookies on Chrome and Safari but not Firefox.

    The blog I need help with is unlikelyexplanations.com.

  2. The button works for me and I am using Firefox 21. Please upgrade your Firefox here http://browsehappy.com/

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache: http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

  3. Hi Timethief,

    Thanks for looking into this. It still breaks for me with Firefox 21.0. It only fails for me under very specific circumstances, so if you don't mind, would you please see whether you can reproduce the problem by doing this:

    1. Go to https://unlikelyexplanations.com (it's important that this is httpS, not http).
    2. Scroll all the way to the bottom of the page.
    3. Click on the "Older Posts" button.

    When I do this with httpS, I don't get any additional posts, and the "Older Posts" button disappears.

  4. This Connection is Untrusted

    You have asked Firefox to connect
    securely to unlikelyexplanations.com, but we can't confirm that your connection is secure.
    Normally, when you try to connect securely,
    sites will present trusted identification to prove that you are
    going to the right place. However, this site's identity can't be verified.

    What Should I Do?

    If you usually connect to
    this site without problems, this error could mean that someone is
    trying to impersonate the site, and you shouldn't continue.
    unlikelyexplanations.com uses an invalid security certificate.

    The certificate is only valid for the following names:
    *.wordpress.com , wordpress.com

    (Error code: ssl_error_bad_cert_domain)

    I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  5. Thanks!

  6. You're welcome.

  7. Will you please do the same for my blogs and let me know if you get the "Untrusted Connection" warning ?
    https://onecoolsitebloggingtips.com
    https://thistimethisspace.com

  8. Yes, I do. I get this on every wordpress.com-hosted site with a custom domain.

    (I verified this with your site just now, but I know this is true in general because I use the "HTTPS Everywhere" extension, which tries the https version of every URL by default, even if I type in or follow a link to the plain http version. I just allow Firefox to accept the wordpress.com certificate for those sites).

  9. Thanks for doing that and providing your results. SIGH ...

Topic Closed

This topic has been closed to new replies.

About this Topic