Need help? Check out our Support site, then


Older Posts Link Not Working

  1. Link to my Blog:
    http://ningdirectory.wordpress.com/

    I think I'm doing something really dense. I'm new to WordPress, other than several years back. My Older Posts link does not work properly. I think this may have something to do with how I have my pages setup, not sure it's correct. I have 2 static pages:
    1. About Ning Directory and,
    2. Ning Twitters.

    The Ning Twitters needs to be my home page. This is the most important factor of the blog. All is well and great, except this link issue. And, in my case of embedding blog in iFrame at: http://theningdirectory.ning.com/page/ning-directory-twitter-blog - - I really need this link to work.

    Under Quick Edit, Ning Twitters Page: Main Page (no parent), Order 1
    Under Quick Edit, About Ning Directory Page: Main Page (no parent), Order 2
    I also tried orders 0 and 1, respectively.

    Under Settings/Discussions/Other Comments Settings:
    Break comments into pages with 15 comments per page and the last page displayed by default.

    My goal for Older Posts Link: While user is on page: Ning Twitters, clicks on Older Posts, takes them to older comments for this specific page.

    Can anyone help? Please let me know if I need to provide more information. Sorry if I gave too much. :-)

    Thank you in advance,
    Jen

    The blog I need help with is ningdirectory.wordpress.com.

  2. I think I messed up on this question. Everywhere I use the words: Older Posts, technically it should say: Older Comments.

  3. This is actually your BLOG page:
    http://ningdirectory.wordpress.com/about-ning-directory/

    and this is a static page:
    http://ningdirectory.wordpress.com/

    I think perhaps you need to review the difference between Posts and Pages:
    http://support.wordpress.com/post-vs-page/

  4. Interesting on the BLOG page link you give me. I would have thought that if any page was the home page, it would be the Ning Twitters. I have the setup of these pages messed up, some how. I read the post-vs-page, and understand this completely. Unfortunately, it didn't help me with my issue. Maybe I'm missing the point. I will research some more, later. Need a break. Thanks for your response.
    Best Regards,
    Jen

  5. I'm not sure I understand what the issue is. If it's the "Older Comments" tab, you just don't have enough comments yet for it to work. If it's the order of pages in your sidebar, you need to go to Appearance>Widgets, click the Edit tab of the Pages widget, select "Page Order" from the "Sort by" scrolldown, click Save Changes.

  6. Honestly, I don't know what I've done. I learned how to utilize most of the basics, very easily. But apparently, the most basic thing, I don't GET. And, that is: what is the actual main blog URL? My thoughts: http://ningdirectory.wordpress.com But, it seems a page I created goes to this main URL. See below.

    When I first setup the blog last night, somehow I made the main blog URL (http://ningdirectory.wordpress.com), what I thought was a page titled "Ning Twitters". When I edit the page "Ning Twitters", the permalink cannot be modified. When I created that page, I thought the permalink would have been http://ningdirectory.wordpress.com/ning-twitters. But it is what I'm calling, the main blog URL.

    It appears that I did create a page titled "About Ning Directory" - - correctly, it has a permalink that I would expect: Permalink: http://ningdirectory.wordpress.com/about-ning-directory

    So, I don't know how to make the "Ning Twitters" a page, instead of the main blog.

    And here is what's happening. When you go to "Ning Twitters" at: http://ningdirectory.wordpress.com/
    I'm only showing 15 comments, and breaking it up in pages, via the Dashboard Under Settings/Discussions/Other Comments Settings. There have been 37 comments made to-date.

    And here is the issue: if you go to the page, and click on "Older Comments", it takes you to a page that has no comments. The link it's going to is: http://ningdirectory.wordpress.com/comment-page-2/#comments

    If you can come up with anything out of this, I would appreciate it so very much.

    Thank you for your time,
    Jen

  7. 1. All the URLs are as expected. The main blog URL is meant to take you to the front of your blog, which can either be your main posts page or a static page (in the second case you usually need to set a posts page as well). You've set "Ning Twitters" as your front, so its URL has become the main blog URL.

    2. Page splits don't work in the front page. If you deactivate the static front option, or set another introductory page as your front, then the "Older Comments" tab of NT will work.

    3. "The Ning Twitters needs to be my home page" (you, first post above); "I don't know how to make the "Ning Twitters" a page, instead of the main blog" (you, last post above). Well, make up your mind!

  8. The "making up my mind" - - can see why you say this, in the context of my statements. But, just a mix up of words and mind, on my part. LOL Sorry about that. Regardless, you have provided very valuable information. This is all I needed. And I thank you. The "Static Front Page" comment is key here. I haven't corrected this yet, but will, soon. I am closing this ticket as resolved.
    Thank you again!
    Jen

  9. Dear panaghiotisadam!
    You are awesome! That took 2 minutes to fix! And that was it. For reference to others: If your "Older Comments" is not working. Make sure you have not set your Front page to a Static page!

    Go to Dashboard/Settings/Reading
    Change "Front page displays" - Your Latest Posts (instead of Static page)

    Thanks again!
    Jen

Topic Closed

This topic has been closed to new replies.

About this Topic