Need help? Check out our Support site, then


Ongoing problem of no space between paragraphs...

  1. I'm joining other posters here afflicted with the no space between paragraphs dilemma. (I'm using the "Redoable Lite" theme.)

    I've read some solutions that suggest switching to plain text, to an external text editor, to editing code... but those are not, in my opinion, acceptable solutions to solving what is a very basic word processing function that has been around since I taught at IBM a hundred years ago.

    I'll be writing to WP Support when it's not down and asking when they are planning on fixing this, and hopefully, it will be soon.

    Apologies if this post sounds terse, but ongoing frustration is seeping through and I haven't had enough coffee this morning...

  2. I, also, continue to have the same problem, intermittently, on both my blogs. My external text editor does not work well with pictures, so more often than not, I compose directly on WordPress. This situation is quite frustrating.

    I have taken to making a little dash to force a paragraph. Looks silly, but is better than having no paragraphs.

    A fix would be wonderful. :)

    Overall, I am quick to say, however, I love WordPress. The company has been good to me.

    Shirley Buxton
    writenow.wordpress.com
    shirleybuxton.wordpress.com

  3. Well, I've tried two different external editors, but by the time it gets to wordpress, the line breaks have been taken out. How does one fix this?!!

  4. @byrningbunny, and you pasting the stuff from the external editor into the wordpress editor to publish it? That would be the only way that I can think of that the paragraph breaks would be stripped out. I've tried and used all the popular editors out there (WLW, Ecto, MarsEdit, BlogDesk, Qumana) and have not had any problems with any of them.

    If you actually publish your blog posts directly from the external editor, the paragraph breaks and formatting will not be stripped out.

  5. I was told by somebody who knows wordpress.com blogs well to use [shift]+[enter] to solve this problem. I didn't try myself, but maybe it is worth trying?

  6. I tried that - shift+enter. It didn't work. I've also tried editing the code and, after I save it, it appears fine, but as soon as I publish it, the breaks are gone again. It drives me batty.

  7. Get yourself an offline blog editor and save yourself the grief of dealing with the editor problems here at wordpress right now: http://onecoolsite.wordpress.com/2007/10/26/offline-blog-editors-reviews/

  8. Ok, I agree, this is really annoying. I have had this same blog, same theme, for over a year, and I used to have no problems putting in paragraph breaks, but now no matter what I do, they don't show up. (And yes, I'm composing right in WordPress, but that is what I expect I should be able to do in a blog).

    So is there a fix with this? Because this is a very very basic problem and if I can't get very basic things like paragraph breaks I will certainly go somewhere else.

    And yes, I tried HTML code which didn't work. And I am using Safari, not Firefox, because it works better on my Mac.

  9. Have you tried replacing the Div tags with the P tags? I advise people with this problem to let staff know directly via their Support button on the Dashboard. That has a LOT more heft to it than a post in the forum (I've tried both for getting a problem fixed, trust me). Meanwhile, all we can do is share workarounds.

  10. If you're using Safari, and refuse to switch browsers, turn off the visual rich text editor under users > my profile. I have yet to have that not work with Safari. At then end of a paragraph, hit return twice.

  11. Firefox v2. Click on 'code' tab, remove all 'div' tags and enter paragraphs with the return key as if you were typing normally in visual.

    Barmy, but seems to work.

  12. I'm using FireFox 2.0.0.12 for Windows and my paragraphs are getting mushed together. I've turned off the visual text editor in my user profile, I don't see any 'div' tags in the code view for my page, I hit Enter twice between lines but they still get removed. I also tried inserting 'p' tags or 'hr' tags, to no effect.

    I tried IE7 and the paragraphs work as expected even after saving using the visual editor.

    An offline blog editor would be a more heavyweight solution for me, as that would involve going through Purchasing for permission to install...

  13. @danielmeyer

    With Windows, you have Windows Live Writer and BlogDesk, both of which are free and both work extremely well with WordPress.

  14. I go to "code" after writing text and insert "ol" at the beginning and end of each paragraph and that seems to do the trick. "ol" (not sure what it stands for) centers your text and I think makes the posting more readable.

  15. linguisticacultural
    Member

    I use a some handicraft method to get spaces between paragraphs: I write dots in different paragraphs, as many as the space I want, then I click "Show advanced toolbar" in Text Editor, and I go to "Select text color". Then I select all these dots and I click "white". You can't see the dots after this. So easy!

  16. thesacredpath
    Staff

    You shouldn't NEED to do this though.

  17. This is a huge problem that basically makes WordPress useless to me.

  18. @peelagrape. Think about an offline blog editor as a solution for now. There will be a big upgrade coming here at wordpress.com with an update to the editor that I have my fingers crossed will take care of all the editor problems, but of course I cannot know that for sure as I'm just a blogger like you.

    http://onecoolsite.wordpress.com/2007/10/26/offline-blog-editors-reviews/

    If you are on Windows, I would stay away from WLW for the moment since it currently seems to be having some issues here at .com.

  19. I hope they fix this soon - I am pulling my hair out along with everyone else. It wasn't long ago that this problem did not exist. All I am doing is composing in the WordPress.com text box with Rich Text features and using the Return key twice on my keyboard to create a new paragraph with a one line space between the two paras. In every other place I have used this feature it works properly. Only on WordPress do I get problems.

  20. See the post right above yours.

    No one here knows when this problem is going to go away. I expect it will go away on the next big upgrade when the user interface and everything changes and the new version of the editor comes online, but that may be a month or two down the road.

  21. I'm waiting for a fix too. External blog posting programs don't recognize wordpress's cool ability to affix a password to individual posts, so I have to use the WordPress editor. When I first started using this service, paragraphs worked fine, then recently stopped working. I don't want to have to type code in.

    Do they not know about the problem?

  22. I've given up trying to read the mind of WordPress.

  23. I've had this problem for months and have found it to be a consistent issue with every theme used and with every browser I've used it on. It is the single most annoying problem that should be addressed immediately! Trying to post anything takes about 10 minutes, because I'm futzing with p and br tags with every post. I'm about ready to switch back to MT4! C'mon guys and gals---fix this!

  24. I too am having problems with this. Not only can I choose to have something single spaced when hitting enter, I can not add extra spacing-- which makes things particularly frustrating when trying to post something like a poem where I need to be able to separate the stanzas. I tried entering
    into the code and that did not work either. Theme: Ambiru by Phu http://dlmtleart.wordpress.com

  25. To get just a return at the end of a block of text, without the blank line, you hold shift and press return/enter. In the graphic design/page layout world it is called a soft return.

    I've just tried several of the tricks I had used before to get two lines between blocks of text, and none of them work (actually they didn't work all that well before).

    The only thing I can suggest to get two lines between stanzas is to use shift-enter and then on the blank lines, put a period and then change the color of the period to the background color of your text area.

    You have to remember, the web is NOT a word processor or a page layout program and is subject to the rules of HTML. In HTML, an additional paragraph return will be stripped out as will two spaces between words or sentences. That's HTML, that is how it is.

  26. For poem formatting, you should be able to use the "pre" tags, but although the editor will keep extra spaces between words in a line, it will not keep extra spaces at the beginning of a line, and it will also not keep extra lines between blocks of text. This sort of goes against the use of the intent with the "pre" tags which is to keep the formatting of text inserted into an HTML document.

    It looks like there are some changes coming on the editor handling of the "pre" tag down the road a little.

    The only drawback on the pre tags is that they force a monospaced font which some may not like.

  27. thanks that helped.

  28. @dlmtleart

    I've played a little, and what you have to do is turn off the visual editor and then do the pre tags and formatting by hand. WordPress still will not honor an extra line between stanzas or paragraphs, but there is a workaround that works as long as you have the visual editor off. Put`<p> </p> on a separate line between and it will give you two blank lines between the stanzas.

  29. Oops, forgot the ending backtick<p> </p>

  30. You don't have to do any of this. Go to perma link and bringt he post up for editing in visual. Highlight the post. Go to format. Choose paragraph. Go to justify and justify the text. Go to Save. Hit save. Go to view post. View post. It worked for me and I am virtually clueless.

Topic Closed

This topic has been closed to new replies.

About this Topic