Need help? Check out our Support site, then


OpenID failure.

  1. I would like to retract my comment above. The bl---y thing just does NOT work. That'll be the very last time that I touch it. Grrrr.

  2. The You don't own that identity errors should be gone.

    If you still experience any troubles, please give a detailed description, something like clconway's:

    http://en.forums.wordpress.com/topic/openid-failure/page/2?replies=48#post-243714

    All the details really helped to understand and fix the problem.

  3. With http://procrastiblog.com it goes through on the first try. Thanks!

    Now, is there a way to change the user information it provides? It displays "procrastiblog.com" instead of "Chris" (or "clconway" or whatever else).

  4. Certainly. I had my site http://dickiebo.wordpress.com open. I tried to put a comment on a site http://www.oldageisabitch.blogspot.com/ and was told to sign in! Needless to say, I lost my comments in the process, as always has happened.

  5. dickiebo, were you logged in or you just had your site open? Did you try signing in after you were asked to?

    clconway, this is strange, it doesn't happen for my codeleter.net -- it asks me to confirm the nickname every time. I will have a look what's causing it.

  6. nbachiyski; I have just opened my site - which is howcome I'm here! - left it minimised, then went onto my friend's site. There I wrote a Comment and tried to use the Open ID. A page came up saying 'You need to sign in'. this then automatically deleted my Comment. How flippin' annoying is this!

  7. dickiebo, it didn't delete your comment. You need to sign in in another tab in the same browser window and then just refresh the page, which says 'Sign In'.

  8. Thnx for your help.I think I'll just stick to the easier system of entering my name and URL.

  9. Hi,

    nbachiyski, I've gone through all your suggested fixes, but am having trouble with my openID and http://stackoverflow.com. When I go to log in there, I get the "You need to sign in" wordpress page, although am already signed in ... I've tried logging out, clearing cookies and cache but still get the same "you need to sign in" page.

    On the stackoverflow site, there is a note that says "you must enable OpenID support with your preferred provider!"

    Do I enable my openID in my WP account? I've look all through the profile settings but have not found anything that needs 'enabling'.

  10. aaronmoodie, it worked fine for me on a mapped domain: http://stackoverflow.com/users/13034/codeleternet

    Here is what I did:

    1. I tried to login on stackoverflow with codeleter.net
    2. It wanted me to sign in
    3. Opened wordpress.com in another tab and logged in
    4. Refreshed the page, which said I had to sign in
    5. VoilĂ , I was registered
  11. nbachiyski, thanks for getting back to me, but still no joy. I don't have a mapped domain. Would this be an issue?

    I went through your steps exactly on FF3 and safari3 (which i don't use much, so there was no cookies) and neither worked. When i get to step 4 and refresh the page, I just keep getting the same "Need to login" screen.

  12. No joy for me either on stackoverflow.com - I get the same results as aaronmoodie. Nbachiyski, I think you ought to try again using an unmapped domain...

  13. nbachiyski, I'm still not having any luck with this. Would it be a mapped domain issue? I can't ask any questions on stackoverflow as I can't login ...

  14. In case people have forgotten this troublesome feature; I have again today tried twice to use the 'Wordpress.com' signature on another blog's comments feature, ( http://wiseherb.blogspot.com/2008/10/autumnal-mutterings.html#comments) only to lose both comments, and continually being stupidly asked to 'sign in'. Clearly there has been no improvement since my last gripe on Sept. 8th!! Really, sooooo annoying.

  15. I just tried it on the site dickiebo mentioned.
    The problem is in the prompt that asks for [username].wordpress.com
    The correct OpenID to enter is [blogname].wordpress.com

    I figured this out by looking at the OpenID page on my wordpress.com blog page. It's a tab in the upper right area of the page.

    The instructions provided by OpenID.net (http://openid.net/get/) also incorrectly specify the format for the WordPress OpenID. I sent them an email this morning to let them know, but others may wish to email them as well.

Topic Closed

This topic has been closed to new replies.

About this Topic