Need help? Check out our Support site, then


Page Load Speed, Controlling Number of Posts on Front Page

  1. themilitarysuicidereport
    Member

    While WordPress.com is generally wonderful, it is not without frustrations. Here are two issues I am having ongoing difficulty with:

    1. Setting/controlling the number of posts that appear when blog front page loads.

    I did not really notice until just recently, but when the blog's main page tries to load, it seems to load unlimited posts ... which causes an annoying delay. Previously, the blog would show only three of the most recent posts on its front page. If one wanted to view more than that, they would have to click on "older posts" in order to leave the current page and load the next three in order.

    This changed -- now the main page loads many posts -- without any action taken and I do not know how to make it return to the way it was where the main page loads JUST the three freshest posts.

    : (

    2. Controlling the email address where copies of new posts are sent

    Prior to about July 18, every time a new posts was loaded, a copy of that new post would be sent to the administrative email address that was designated in the admin settings and this system worked flawlessly.

    Then, without any action taken by the blog administrator, the emails stopped arriving in the email inbox. This was a big mystery and there are several posts that are listed in this support forum about this.

    I have found that new posts are indeed generating emails, but they are going to another email address other than the one I have designated ... wow, how frustrating this is.

    How to I fix this issue???

    Why did this email designation change, apparently all on its on???

    Thanks in advance for any answers you can provide me on these two frustrating technical problems I can't seem to solve on my own.

    The blog I need help with is themilitarysuicidereport.wordpress.com.

  2. 1. Setting/controlling the number of posts that appear when blog front page loads.

    Staff have been introducing “infinite scroll" to themes — a site wide change that will be applied to all themes that are suitable for the implementation. http://en.forums.wordpress.com/topic/to-infinity?replies=137
    http://en.blog.wordpress.com/2012/06/12/to-infinity-and-beyond/

    Disabling" the infinite scroll feature to get rid of the pop-up in the footer results in a "Load More Posts" tab, and you can't disable that "Load More Posts" tab from appearing and have "previous post" and "next post" links, without the Custom Design upgrade. http://en.support.wordpress.com/custom-design/

  3. 2. Controlling the email address where copies of new posts are sent

    You have two separate email address settings at WordPress.com and in both cases it's you who provides the email address:

    Blog notifications for the admin (like comment moderation, Likes, new subscriptions, etc) are sent to the email address at Settings -> General in the Dashboard.

    Personal notifications (like comments on your post, subscription emails, and upgrade renewals) are sent to the email address at Users -> Personal Settings in the Dashboard.

    See > Issues Changing your E-mail Address > http://en.support.wordpress.com/email-address/#issues-changing-your-e-mail-address

    Please confirm your settings are correct here > Settings > Discussion
    Also confirm the correct email addresses are entered at
    the Settings tab on the WordPress.com home page, and
    Users -> Personal Settings in your dashboard
    Also note this please > http://en.support.wordpress.com/email-notifications/#what-if-the-emails-arent-getting-through

  4. themilitarysuicidereport
    Member

    Thank you for your prompt response.

    I remedied the issue with being able to control the number of posts appearing on the main page when it loads.

    I did this by adjusting the values at Settings > Reading

    This did not require an upgrade to Custom Design as you have suggested, although I am sure that would work as well.

    Now, on the issue of the email ... I am at a loss.

    As you suggested, I checked and verified both email address locations and confirmed that I have the correct email address (same one in both sections) that was entered when this blog was first published.

    This correct email address was receiving regular updates for more than 100 of the blog's first posts.

    But suddenly, without making any changes, around July 18, the emails stopped. Now when a new post is loaded on the blog, emails are being sent to another email address that is not entered in either of the areas you mentioned. Copies of new posts are being sent to an email address (same ISP) but, the email address is not the one entered in the administrative settings for this blog.

    Frustration continues on this unresolved issue.

  5. This did not require an upgrade to Custom Design as you have suggested, although I am sure that would work as well.

    I did not make such a suggestion at all.

    1. Setting/controlling the number of posts that appear when blog front page loads.

    Staff have been introducing “infinite scroll" to themes — a site wide change that will be applied to all themes that are suitable for the implementation. http://en.forums.wordpress.com/topic/to-infinity?replies=137
    http://en.blog.wordpress.com/2012/06/12/to-infinity-and-beyond/

    Disabling" the infinite scroll feature to get rid of the pop-up in the footer results in a "Load More Posts" tab, and you can't disable that "Load More Posts" tab from appearing and have "previous post" and "next post" links, without the Custom Design upgrade. http://en.support.wordpress.com/custom-design/

    This thread has been flagged for Staff attention. They will assist with your second issue.

  6. themilitarysuicidereport
    Member

    So, SO sorry. I did not carefully read you comment re: custom design.

    Thanks again for your help and sorry for the careless mistake and the comment. I somehow missed the all important word "without."

    Again, very very sorry for that.

    I so appreciate the service WordPress facilitates and will be very careful to read posts like yours more slowly and carefully.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • Started 1 year ago by themilitarysuicidereport
  • This topic has 6 posts
  • 2 posters
  • Latest reply from themilitarysuicidereport
  • This topic is not resolved
  • RSS feed for this topic