Need help? Check out our Support site, then


page very slow to load

  1. The page is very slow to load. This days I am getting frequent offer of option TO KILL or Wait:
    * to publish when new post is posted;
    *to find any post or go through different posts.
    *Finally, I received complaint about the same problem from one webpage, which wanted to link.

    Would appreciate some help.

  2. You can decrease your page loading time by inserting "the more tag" into your posts and displaying only the beginning of posts on your front page followed by read more links that your visitors can click and then view the whole post on it's own page. If you blog has infinite scroll and you have lost control over how many posts are displaying on the front page then you can disable infinite scroll by using a workaround.

  3. Thank you for your contribution. The beginning of the webpage has been as you said. I just disabled the infinite scroll, but no significant change. It is still slow to load!
    Thanks all the same.

  4. The page is very slow to load for me as well, in Vancouver. I got a notice it was loading from "Sweetmarias" so whatever that is, disable it.

  5. help please! I tried every means, but it takes ages to load or call a page! Help!!!!!!!As I said before, WordPress is only signalling either the wait or kill option!

  6. Your blog is broken. http://ismyblogworking.com/transformingethiopia.wordpress.com This thread is flagged for Staff attention. I do not recommend that others click the link as doing so crashed my browser when I did.

  7. Your blog has 245 sticky posts.

    Sticky posts override the posts per page setting, which means that your blog isn't done loading its front page until it loads all 245 posts.

    You'll need to drop your sticky posts down to a much more conservative number, like 5.

Topic Closed

This topic has been closed to new replies.

About this Topic