Need help? Check out our Support site, then


pages

  1. justcallmeerinbrockovich
    Member

    Hi, I'm sure I'm missing something, but I'm trying to create a new, second page in addition to my 'about' page. It will be my Funders hall of fame' page. I want this new page to appear after the 'about page'. I've tried making the 'about' page a parent, and also choosing the order of the second page as '2' in the attributes part, but no joy. It still appears at the top of the page, infront of the 'about' page?

    The blog I need help with is justcallmeerinbrockovich.wordpress.com.

  2. There are two approaches you can use. This first one is when you only have Pages.

    1. Page Order - Page attributes module order numerically rather than alphabetically.
    http://en.support.wordpress.com/pages/page-attributes/#order
    http://en.support.wordpress.com/pages/page-attributes/

    2. This approach is for those who have created a custom menu and have added pages to that custom menu.
    create a custom menu http://en.support.wordpress.com/menus/
    add the pages and sub-pages http://en.support.wordpress.com/menus/#adding-pages
    order them http://en.support.wordpress.com/menus/#changing-the-order-of-menu-items-and-creating-sub-menus

    Troubleshooting – My pages are in the wrong order
    If you have a custom menu then you must establish consistency. Check the Pages sub-pages themselves to see if you have established a Parent page and child page “hierarchical structure” in the page attributes module. Remove if required.

    Also remove any “order” numbers you have assigned that may conflict with the order you are creating by dropping and dragging. Or simply change them so they are the same order as you establish in the menu. Establish consistency – problem solved

  3. justcallmeerinbrockovich
    Member

    Thank you so much for your kind help. Unfortunately I have tried both approaches (my page does support one custom menu) but still no luck.

    When I add the second page, it appears first, above my about page (as if appearing in a timeline). I wonder if it's to do with the current design template I have?

  4. Are you creating PAGES or Posts? That sounds like Post behaviour.

  5. justcallmeerinbrockovich
    Member

    Page, promise! I went step by step through the advises above! I'll try again tomorrow but its driving me nuts because I've just started to get followers and need to fix! X

  6. When you say you want this new page to appear after the About page, do you mean the actual content of the pages, or the links to those pages in the sidebar (or the top menu)?

  7. justcallmeerinbrockovich
    Member

    If i follow the steps outline above it appears perfectly in the side bar i.e 'About' (parent) 'Funding' (child)

    but on the static homepage itself, when opening the webpage, the sceond page (funding) appears first, at the top of the screen and then as you read it and scroll down, you get to my 'about' page.

  8. That's not possible: the blog front can only display one static page. Please publish the page so we can see what you mean.
    (And, are we talking about http://justcallmeerinbrockovich.wordpress.com/ or about a different blog?)

  9. justcallmeerinbrockovich
    Member

    It's published now: parent page is 'about' second page is 'funder.' As you can see the funder page appears first, as if it were a post?

  10. Now this is driving me nuts! As you can tell from my previous reply, this isn't supposed to be possible, I've never seen it before, and I can confidently say that raincoaster and timethief would say the same (we are three of the most experienced volunteers here).

    I examined the code of your front page and I can't find any errors. I tried to replicate the situation in my blog (down to copying and using the whole code of your page as well as your title with the #, your extra long tagline, the sharing buttons and everything) and I can't.

    One suggestion (since I used the code of your page and got the right results) would be to try replacing the page with a fresh one:
    Edit the About page, switch the editor to Text (=code), select all, copy.
    Create a new page, title it About Me to avoid any possible confusion (you can change that afterwards), paste the content you copied (into the Text editor again), publish.
    Trash the About page, edit the Funders page to set About Me as its parent, set your front to display About Me in Settings > Reading.

    By the way, why do you want the Funders page to be a child page?

  11. Are you referring to http://justcallmeerinbrockovich.wordpress.com/ ?

    The "Funders Hall of Fame" Page is still set as a Draft. Would you please Publish it so we can see the problem?

    You also have a Draft Post titled as "Funders Hall of Fame".

    Make sure that you publish the Page, not the Post.

  12. justcallmeerinbrockovich
    Member

    Guys, you are very kind for helping me and sticking with me!

    yes, http://justcallmeerinbrockovich.wordpress.com.

    Justpi, i have followed your instructions, thank you! Wasn't fussed about the parent/child aspect, just wanted About me to appear first and it now does.

    But (being the perfectionist) the Funding page still appears below About me on the Home Page. The About Me and Funding pages however appear separately and beautifully if you use the tabs at the top... so I in effect appear to have three pages:

    1. Home = About me and below it Funding
    2. About Me
    3. Funding

    There also appears to be three strange blue squares on the home page which appear at the very bottom of the page. I wondered if that pointed to there being a possible issue with my coding/Gravatar Hovercards?

    Thanks guys, its already looking so pretty despite my imcompetence!

  13. justcallmeerinbrockovich
    Member

    macmanx, thank you, think i have rectified!?

  14. You're welcome! It looks good to me, mostly.

    Now, at Settings -> Reading, you have chosen to have a static front page, but have not selected one, and have not selected a Posts page.

    Select a page for both, or switch back to "Your Latest Posts" and that should fix everything else.

  15. justcallmeerinbrockovich
    Member

    MacManx, thank you so much you are a miracle worker! looks brilliant, so thrilled that I (with no computer skills) managed it with everyone's support.

    i love wordpress!

  16. You're welcome!

  17. James, the current setup simply sidesteps the issue. The issue was that when the Funders page was published as a child to About, the blog front displayed both pages, like two posts.

  18. justpi, that's because the justcallmeerinbrockovich also had a post titled the same and choose to use a static front page with no set front page or posts page.

    When that happens, some themes display all pages and all posts on the front page.

    There really isn't an issue here, the only problem is that justcallmeerinbrockovich hadn't finished setting up the static front page at the time.

  19. No, James, it was a bug: you can't "use a static front page with no set front page", the blog didn't display "all pages and all posts on the front page", it displayed the two pages only, along with an erratic comment section, and this showed up when the one page was set as a child to the other.

  20. Justpi, I don't think you're understanding me here, and I'm not sure why we're discussing this after the issue had been resolved.

    It's not a bug, it's something I have seen plenty of times, but it is not a bug.

    A user is more than capable of going to Settings -> Reading in their blog's Dashboard, selecting "A static page," skipping the specific page choices, and hitting "Save Changes" at the bottom of the page. Some themes allow this due to their design, but you can also recreate the condition on all themes by simply deleting the chosen pages.

    When this is done, some themes display all pages and posts on the front page due to how they are designed. The user also had a post and a page both titled "Funders Hall of Fame" with the same content, further adding to the confusion.

    Trust me, I know what I'm doing here, that's what I saw, that's what I diagnosed because I've seen it before, and that's what fixed the problem.

    At the end of it all, it was simple due to a setting that had not yet been completely filled out, a perfectly reasonable mistake.

  21. I don't think you're understanding me either (in fact you aren't even listening), and we're discussing this because I think I saw a very unusual bug and because your explanations aren't convincing.
    a) I tried everything the OP had tried, using the theme she's using, and I couldn't reproduce the issue.
    b) If I go to Settings -> Reading, select "A static page," and skip both page choices, the result isn't what you're saying: the selection automatically reverts to "Your latest posts" when I click "Save Changes" (in both browsers I use); if I select a posts page but skip selecting a front page, the selection sticks but the blog front displays the latest posts.
    c) If I select a specific static page as the blog front then trash the page, again the result isn't what you're saying: the result I get is a 404; if I then delete the page permanently, the blog front displays the latest posts.
    d) The OP's front didn't display "all pages and posts", it displayed two static pages only, plus a malformed comment section below the About page.
    e) The About page did show up correctly as the blog front from the start, and the problem cropped up when the Funders page was turned into a child to the About page.
    f) The issue was "resolved" because the Funders page isn't a child page anymore - which is what I wanted to suggest anyway (that's why I asked the OP "why do you want the Funders page to be a child page?").

  22. I think we'll just have to agree to disagree. First, a few points for clarity.

    If I go to Settings -> Reading, select "A static page," and skip both page choices, the result isn't what you're saying: the selection automatically reverts to "Your latest posts" when I click "Save Changes" (in both browsers I use); if I select a posts page but skip selecting a front page, the selection sticks but the blog front displays the latest posts.

    Yes, that only works on some themes. To reproduce it on all themes, set your front and posts page, then either delete those pages or set them as drafts (you'll need other published posts and pages to see the mess). I suppose that may not even work on all themes, but it works on more that just not choosing pages. The issue is related to how the theme is designed, and I haven't tested all 220 yet.

    The OP's front didn't display "all pages and posts", it displayed two static pages only, plus a malformed comment section below the About page.

    Yes, that's a variation of the problem, but still the same problem. The comments section was coming from the page. To clarify, the issue is with how a theme behaves when the setting is accidentally invalidated. It's not an ideal situation, probably not consistant, but not really a bug. We are looking into it, but it's not as high priority as most cases.

    The About page did show up correctly as the blog front from the start, and the problem cropped up when the Funders page was turned into a child to the About page. The issue was "resolved" because the Funders page isn't a child page anymore - which is what I wanted to suggest anyway (that's why I asked the OP "why do you want the Funders page to be a child page?").

    I have access to the blog's Dashboard, which I used to investigate the issue, so I am well aware of what resolved the situation. Maybe setting the page as a parent was part of the fix (it was set as parent when I got there, but I haven't been able to reproduce that part of the issue), but the blog was still largely a mess. Finalizing the front page settings is what solved that mess.

    Overall, the issues was an accidentally invalidated front page setting, and that is on our watchlist.

    I'm not saying that you didn't have a hand in resolving this, but from my perspective, finalizing the front page setting solved the messy front page, which is what I was focussing on.

  23. Yes, that only works on some themes.

    Jesus! I tried all that using the theme the OP is using: Greyzed.

    To reproduce it on all themes, set your front and posts page, then either delete those pages or set them as drafts (you'll need other published posts and pages to see the mess).

    I do have other published posts and pages, and I saw no mess: if I set the pages as drafts I get a 404 on the front page, and if I delete them permanently I get the latest posts. (I'm still talking about the theme the OP is using. I tried it again on MistyLook and 2011, same results. Can you suggest one theme on which I'll see what you're saying I should see?)

    I'm not saying that you didn't have a hand in resolving this

    I did not have a hand in resolving this (except if the OP created a new About page as I suggested and if this made a difference, or if she turned the child page into a main page because of my question), and that's not the reason I'm arguing, so please don't misunderstand me: the reason I'm arguing is my, let's say, 'scientific' interest. I visited the blog several times before you did, and I saw what you never saw: the About page displayed correctly as the blog front when the Funders page was a draft, and the mess showed up when the Funders page was published and set as a child to About. You don't want to put this on your watchlist, fine, I give up.

  24. Like I've said, I tried what your describing and couldn't reproduce the issue. All I know is what I saw when I looked at the blog, and how to fix that.

    If there was something that existed and was fixed before I saw the blog, then that would explain a lot, unfortunately I can't do much at about that. If it ever happens again, and I can see it in action with no changes, that would be great.

Topic Closed

This topic has been closed to new replies.

About this Topic