Need help? Check out our Support site, then


Paragraph formatting with the new editor

  1. I have done a lot of testing, and also a lot of research on the TinyMCE site, and also by going through piles of tickets at trac.wordpress.org regarding the new editor and have found out how to keep paragraph formatting.

    When you start a new post, make certain that in the format pulldown (left end of lower visual toolbar) says "Paragraph." If it does, then in every browser I have tried, the editor will keep the paragraph formatting with blank lines between paragraphs.

    The blockquote, unordered list (bulleted) and ordered list (numbered) functions now have to be toggled on and off via the buttons in the toolbar.

    Entering a list

    1. click on ordered or unordered list to start the list
    2. enter all the list items
    3. when done, hit return/enter (like you are going to add another item to the list) and then click on the toolbar list button to end the list

    If you follow the above with lists, when you hit the list button to end the list, the editor will automatically switch back to paragraph formatting.

    It's the same with blockquote

    1. click on blockquote button
    2. enter the quoted material
    3. when done, hit return/enter one more time and then click on the blockquote button to exit the blockquote function

    If you end up with paragraphs without lines between them, that means you are not in paragraph formatting. Select the paragraphs that are not formatted properly and then select "Paragraph" from the format pulldown (left end of lower visual toolbar) and the paragraphs will be formatted with paragraph breaks.

    Always keep an eye on the format pulldown as it will indicate how formatting is set in the editor. When doing blockquotes and ordered and unordered lists it will indicated "format."

    The bottom status bar on the editor also indicates how things are set:

    Blockquote: Path: blockquote » p
    Unordered list: Path: p » ul » li
    Ordered list: Path: p » ol » li

    If you see "Path: p » div," you are not in paragraph format and will not get blank lines between paragraphs

    In paragraph format mode, you will see "Path: p."

  2. ok, i've check every word of my posts and it's still mash up all the paragraphs...i've use firefox, flock and epiphany (i'm an ubuntu linux user) and still have this problem...do you have any idea how to restyle my posts, cause they look pretty messy...
    this is an example: http://sitemarca.wordpress.com/2008/04/07/yahoo-responde-a-la-oferta-hostil-de-microsoft-sumando-nuevas-funciones-a-su-plataforma-publicitaria/
    http://sitemarca.wordpress.com/2008/04/07/la-ley-de-proteccion-de-datos-personales-comenzara-a-tener-aplicacion-en-argentina/
    http://sitemarca.wordpress.com/2008/04/07/la-liebre-amotinada-y-critica-de-la-argentina-unidos-por-una-bicicleta/

  3. When starting a new post, make certain that the format pulldown in the visual editor says, "paragraph," and not just "format."

    On existing posts with no paragraph break, select all the paragraphs while in the visual editor and then go to the format pulldown and select "paragraph" to correct the formatting and it will put in the line breaks. In my testing with Firefox, IE and Safari 3.1, the formatting has always held after I have done that.

    I have only tested in XP and Mac OS X 10.4.11, and do not know if this will hold in Linux.

  4. A clarification. If you also have lists or blockquotes, you will have to select the paragraphs around the lists and blockquotes separately. If you include them when you select paragraph from the pulldown, they will remove the blockquote or list formatting and turn them into standard paragraphs.

  5. Seems to work with FF 2 in Fedora 7.

  6. I think a lot of it has to do with whether the "paragraph" formatting is selected when you start to compose a post. Some of the TinyMCE settings are held in the database, so if it is set to "format" rather than "paragraph" then TinyMCE will remember that. At least that is what I have found.

    It's good to know FF in Fedora 7 is working OK. It could be that if those having problems selected "paragraph" from the pulldown when they began their next post, it would stick and they wouldn't have to worry about it from then on as long as they entered and exited blockquote, and lists properly.

  7. Thanks for the tips, sacredpath. Unfortunately I can't see any "format pulldown (left end of lower visual toolbar)".

    I've already checked 'use visual editor' in My Profile, which is the setting I've always used. However, in the new dashboard, the Visual Editor merely shows me HTML tags and I can't click on the HTML tab. :(

  8. P.S. The comments I just made refer to Firefox 2.0 on WinXP. I just tried logging into my WordPress Dashboard from Firefox on a Mac and the Visual Editor is fine. Any suggestions how to get it working on my Win Firefox? Many thanks.

  9. Click on the last icon on the right end of the toolbar (looks like a square with rows of dots in it) and it will bring up the second row of icons. The format pulldown is at the left end of the lower row.

    On XP, with the editor page open, do a forced reload. I've had to do quite a bit of force reloading in XP with FF and IE, but now that I've forced reloads on everything it is working smoothly.

Topic Closed

This topic has been closed to new replies.

About this Topic