Need help? Check out our Support site, then


Password Protected Pages - Problem

  1. HI there,
    I have several password protected pages. They worked fine the last couple days- lot's of readers were able to log in- but now all of a sudden, the password doesn't work. You can't neither log in on any browser to view the page, nor can I even as an logged in admin from my page in the Dashboard preview or view my page. Any ideas what the problem is- or is it just a glitch with wordpress.
    Thank you so much for your help!
    Nat

    The blog I need help with is nathaliesstudio.com.

  2. Hello there,
    Will you please contact Staff and provide them with the details such as the posts URLs etc. so they can help you?

  3. cindyagoncillo
    Member

    I am having the same problem. I have tried changing the password, but that didn't work. I have tried while logged in and out, neither of those worked.

    Somehow I was able to get it to accept the password, but I'm not sure what I did. I DID notice, however, that when I was able to access the protected post, the URL was cindyagoncillo.wordpress.com - I have my site mapped to cindyagoncillo.com. I am unable to access the post on the mapped URL, but I cannot figure out how to access the wordpress.com URL anymore.

  4. @cindyagoncillo

    the URL was cindyagoncillo.wordpress.com - I have my site mapped to cindyagoncillo.com. I am unable to access the post on the mapped URL, but I cannot figure out how to access the wordpress.com URL anymore.

    As you have domain mapping you will always see the .wordpress.com subdomain URL on the Admin side of the blog. That's is normal. This is the URL that visitors see http://cindyagoncillo.com/2012/01/06/dream-journal-all-kinds-of-crazy-part-two/

  5. cindyagoncillo
    Member

    @timethief
    That is not the issue. The problem is not being able to access my protected post, even when I am logged into my wordpress account. I can only see the post through the .wordpress.com URL, which I can only access by updating the post and clicking "view post" from the edit page - an option that is obviously unavailable to anyone else who wants to read the post.

    Is anyone else having issues with protected posts on mapped domains?

  6. I'm having the same problem as well. I've checked and double-checked the password, but I can't log in with it.

    The page is http://freshbnb.com/4freechapters/

    Thanks timethief for posting the contact staff link—I'll send them a note right now.

    Nala

  7. It is the exact problem for me @cindyagoncillo- mine is a mapped domain too.

  8. @timethief- thank you I will!

  9. projectgoldenhinde
    Member

    I have the same problem and have just contacted support to see what is happening.

  10. cindyagoncillo
    Member

    My temporary solution is to turn the protected post into a public contact form so people can email me for a copy of the post. Not ideal, but it will have to do for now.

  11. @cindyagoncillo I have to email the download document to my visitors as well as a temporary solution. The pain is, I am giving this document away as a thanks for subscribing to my newsletter, so now I have a chain of emails I have to rewrite. Sigh.

    My domain is also mapped. I wonder if that's a contributing factor?

  12. cindyagoncillo
    Member

    It seems like the mapping is the common factor with everyone having this issue, but I'm not sure why it's causing this problem.

  13. Please check your browser to make sure you're allowing third-party cookies. Several features of WordPress.com require these to be enabled when using mapped domains. I hadn't run across the issue for private posts, but it seems a possible cause. You can read some instructions for enabling third-party cookies here.

  14. It was tried on three computers- pc/mac - four different browser and it didn't work- as well as not for several hundred people that tried it and were sucessful weeks ahead. So it can't be the thrid party cookie issue.

  15. So it can't be the thrid party cookie issue.

    @natel: Is that an assumption or a fact? Have you checked if the third-party cookies are enabled (at least on one computer)?

  16. @natel: I stand corrected ... My third-party cookies are enabled and I still can't view a certain password-protected post on a custom domain name.

  17. I have the third party cookies enabled !

    I just can't figure it out what is going on.

    Why would it occur from one minute on the other on all browser- on different computers? I just ask- as I have 4000 subscribers to a page that is now blocked on all their different computers.

    And I am just a bit wrecked since I get a huge volume of emails complaining because they can't access the pages anymore.

  18. @airodyssey : No worries :) I wish it would have been that

  19. Would you like to try some other troubleshooting techniques so we can isolate what's causing this blockage?
    Are you using http:// or https:// see http://en.support.wordpress.com/https/
    Have you tried using the browsers with all extensions or add-ons disabled?
    Do you have JavaScript enabled?

  20. @timethief

    Are you using http:// or https:// see http://en.support.wordpress.com/https/
    No
    Have you tried using the browsers with all extensions or add-ons disabled?
    no add ons
    Do you have JavaScript enabled?
    yes

    But again - I am not the only one having this problems with my page. I had till a certain time everybody being able getting on after I had sent a newsletter out with the url and the password. Then all of a sudden the emails rolled in that they are not getting into the page anymore. the password would not be taken.I first thought it was mistake by the users- and then tried it again and had the same problem. I then checked a page i had worked on - also password protected - which I had just seen fine an hour before- and I couldn't access it.

    Password protected Draft-Pages are visible in the Preview when I'm logged in, but not anymore once they are published.

  21. @timethief- what I'm triying to say- sorry my english is not good - so I tend to get longer in my sentences:

    It can't be a browser issue from my end - it certainly doesn't work on hundreds of my subscriber's browers anymore - with pages which used to work before.

  22. Thanks for humoring me and checking the third-party cookie issue. I can now verify that the issue occurs for me as well on a test blog. We don't have a fix ready, but the issue is on our radar. Thank you for reporting it! We'll update this thread once we've figure out what's going on.

  23. @dllh - I so hope you can solve it quick :) I have an online workshop that goes live in one week- and it is password protected- I have no clue what to do if this is not solved till then.......
    Thank you guys- you are doing an amazing job- btw - I love WordPress for years now!

  24. @natel Thank you for your patience the issue is now resolved.

  25. @westi - YEAHHHH I checked - it works- you are right.

    YOU GUYS ROCK!!!!!

  26. cindyagoncillo
    Member

    Mine works, too! Thanks for the fix!

Topic Closed

This topic has been closed to new replies.

About this Topic