Need help? Check out our Support site, then


Password protected posts still show pictures as thumbnails in readers

  1. I password protect post specifically to keep pictures private but I have now found that the picture is showing as a thumbnail in e.g. feedly.com. I have reported the issue to wordpress, but with no response, I guess they don't see it as a security issue. But I do. I specifically chose WP for the option to password protect specific posts. Anyone know of this and have a workaround (except putting a nonsense picture in each post).

    The blog I need help with is knasokalas.wordpress.com.

  2. Do ALL of the pictures show in the feed?

  3. No, it is just the first one.

  4. Then until this is fixed (and I flagged it for staff attention) I suggest you upload a 1x1 pixel image as the first image in each post. Nobody will notice that.

  5. Thanks for flagging it. I will use the workaround until it is fixed.

  6. Hi there,

    Thanks for reporting this issue. We do take your privacy seriously, and we appreciate you letting us know about this.

    However, I have been testing this on my end, and I'm not able to reproduce this issue with password-protected posts. I also checked your blog's RSS feed (the information that's sent to feed readers like Feedly) and don't see any images from your password-protected posts there.

    Could you provide some additional details about the posts where you saw this issue? Did it happen with all of the password-protected posts you made, or only certain ones? Also, were those posts ever published without password protection? That additional information will help me investigate this issue further. Thanks!

  7. I have added two posts today to test. In the first one the picture is displaying. In the second one I put a tiny image first as raincoaster suggested and then no image is shown. If there is anyway I can send you a screen shot it might help. And yes, I did password protect them immediately. I understand that they are already cached if you forget the password, but that is not the case here.

  8. Hi there,

    You can upload screenshots to your Media Library under Media > Add New in your dashboard, and I can take a look at them there, or you can use an online service like Snaggy and share the link here in the forums.

    Also, if you don't mind, since I'm staff I can take a look at your test posts directly in your dashboard. That might help me figure out what's going on. Just let me know if that's ok and I can look to see what's going on.

  9. Feel free to access my dashboard, no problem. I have uploaded a screen print displaying the four posts I have tested today. I also added a print of a feed from a friend of mine experiencing the same issue.

    I have tested from chrome, internet explorer and my wp android app. With and without text before the picture, different images etc. All with the same result. (However posts from yesterday that were displaying then are not showing the picture today, but other older posts do so no pattern there either)

  10. Hi there,

    Thanks for the screenshots and that additional information. I took a look at your test posts and your blog's feed, and I don't see any content in your feed that would explain why those images are showing up in Feedly. It's a puzzle!

    I reported the issue to our team, so our developers can take a look at this. I'll let you know as soon as I have more information from them. Please let me know if you have any questions in the meantime.

  11. Hi there,

    Sorry for the delay getting back to you about this. It took some digging for our team to figure this out, but we fixed the cause of this issue.

    It's possible that Feedly has saved those photos from your previous password-protected posts and will keep displaying them. However, photos in any new password-protected posts won't be shown on Feedly. Thanks again for notifying us about this! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.