Need help? Check out our Support site, then


Photos suddenly faded

  1. I spent a chunk of time last week reading through the forums to deal with my images appearing very faded once I uploaded them, and saw that I needed to size them in photoshop at exactly the size I wanted them to appear so that wordpress wouldn't resize them and lose info.

    I did that, and they looked great -- sharp, colorful, pretty.

    I haven't worked on my blog since Friday, but when I clicked on my url this morning, the images are suddenly faded again! How can that be? They looked great -- and dramatically brighter -- last time I looked at my blog, and I haven't touched anything. How and why would they change on their own?

    Here is the specific link to the photos that mysteriously changed:
    http://urbanhausfrau.wordpress.com/2009/08/18/no-bag-left-behind/

    Thanks for reading -- I appreciate any thoughts or suggestions.

    The blog I need help with is urbanhausfrau.wordpress.com.

  2. When you save them from Photoshop, make sure they use the sRGB color space. I believe there's a checkbox for that in the Save For Web feature.

  3. Thanks, tellyworth. I actually tried testing your suggestion this morning -- saved one of the photos into sRGB using the Save for Web feature, and uploaded it. Still faded. Took it back down so the original post w/ photos is there.

    I think it's especially odd that the photos were vibrant at one point and have since faded. If they had been faded the whole time, that would be one thing. But I did resize them to 100%, like I mentioned in my original post, and they looked so sharp for a few days. I feel like I'm going crazy.

    To add to the craziness, the other photo I have on my site -- which was also vibrant and bright -- is now appearing faded as well.

    I can't tell if I'm losing my mind or have ghosts haunting my blog. It's frustrating, too, that the sRGB thing didn't help. Has anyone out there experienced this? I'd really like to get this right for future posts.

    Thank you so much!

  4. Okay, well if anyone cares or is reading along, perhaps this is a clue:

    I've been viewing my site in Firefox, on my mac laptop. Just opened Safari and looked at the site. The photos in my post above are still faded. However, the other photo on my site (the birds in this post: http://tinyurl.com/ngfwf6) are bright and vibrant again in Safari. Switch back to Firefox, and they're faded.

    Crazy!

  5. My process:

    1. Determine the "full-sized" image width for the theme I'm using (from the image insert window).
    2. Create an image that exact width and save it to the desktop as a different name such as image-500.jpg
    3. Upload the original image ( image.jpg )and the smaller image ( image-500.jpg ) I created to the media library.
    4. Insert the smaller image I uploaded and link it to the larger image.

    Anytime you rely on wordpress and a browser to resize an image from say 2000px in width, down to 500px or so in width to display in a blog post or page, you will have a considerable loss in quality. Even if you are only going from 800px down to 500px you will lose color and sharpness.

  6. The good news is this seems to be part of a known bug and there is a work around. The bad news is it's a small hassle to fix.

    I started noticing color loss from iPhoto to WP, and it was driving me crazy. It seems to affect photos differently, and though I don't know see a clear pattern, the worst tended to be those I had adjusted in iPhoto, especially where I had increased saturation. The effect was pronounced fading and lots of pixel noise.

    The workaround actually comes from another thread on the subject of animated gifs-- but I guessed that this might be an extension of the same issue, and so it is. Sacredpath is right that you need to circumvent the WP resizing functions by doing it beforehand in Photoshop, etc.--but that alone will not fix the problem.

    Once you've resized, uploaded, and inserted your photo to the post (having selected the "Full Size" option), you need to click the "Edit Image" icon (left corner), then go to the "Advanced Settings" tab and delete the "Width" and "Height" values in the "Size" row. Make sure the fields are empty (not "0"), then click "Update", and you should be good to go.

    Now the only problem is I've got a masters thesis due in three weeks, and so many bleached out posts begging to be fixed...

    Hope that does it for you. Cheers!

  7. Staff has disabled the "optimization" they had started doing to "full-sized" images so that this does not happen and they are working on a different solution.

    The reason they were doing this, as I understand it, was to reduce bandwidth usage (most people do not optimize their images before uploading) and processing time, and to help make image-heavy blogs load faster. All worth goals of course, but it obviously needs some more work - which is why it is presently disabled.

  8. I'm now finding that this workaround kills my captions, so I hope it gets fixed soon!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags