Need help? Check out our Support site, then


Picture id listed among my top posts

  1. Can anyone explain this mystery to me? (1) For some time now, many internal id's of pictures of mine have appeared in my stats listing of top posts. How do they get there and why? (2) When I click on such a picture id in the list of top posts, I get a display of the post (number 179) to which the picture belongs, but the post appears totally twisted, as follows: (a) the normal post heading, (b) the internal id of the listed picture in headline-sized font, (c) the listed picture itself, (d) miniatures of the other two pictures belonging to post 179. And nothing more - that is all that appears as post 179.

    When I rushed to post 179 in the archive it looked completely normal, thankfully.

    Can anyone explain what happened? What did someone do to get this strange display? Did I code something wrong to cause it? I would be grateful for any help at all.

    My blog URL is gymbrat.wordpress.com

    The blog I need help with is gymbrat.wordpress.com.

  2. @ gymbrat

    It sounds like it is an attachment page. They are usually associated with a gallery.
    http://en.support.wordpress.com/images/gallery/

    On this post:
    http://gymbrat.wordpress.com/category/memoarer/
    when you click on an image, WordPress takes you to an attachment page.
    The post title links back to the original post.
    Inlägg 180: 23 mar – 18 apr 1964
    Clicking a thumbnail will bring you to the next picture in your gallery.
    This is the title of your image:
    B0180_1,CSDF,Free,PåMinLambretta,Fantes/

  3. This is where you might have selected the attachment option:
    http://en.support.wordpress.com/images/gallery/#gallery-settings

  4. (Sorry: got interrupted)
    The other way you'd get an attachment page is by selecting "post url" as in #4 on this support document.
    If you don't want the attachment page, then choose "file url."

  5. Thank you, 1tess, for that precise analysis, and also for the links that you gave me. This "gallery" stuff is new to me. I have been successful so far by using the Support info on "Images" only and therefore always used the "Insert into post" button and never the "Save all changes" (which you have taught me to be the door to the Gallery functions)..

    All that I have, and want to have, is text with occasional inserted pictures, and if you could give me a hint just about how to make the pictures non-clickable, I would be happy as a singing bird. If I could avoid having to deal with the "Gallery" functions at all, then I will continue to live in my happy ignorance.

  6. @gymbrat

    (Blushing with embarrassment) I forgot to put the actual link in my post above:
    http://en.support.wordpress.com/images/

    Choose "none" if you don't want the image to open in a new window.

    Choose "file" if you want the image clickable (so readers can see a larger picture)
    If you want the big image in a plain new page, click the picture, click the mountain icon, go to advanced settings and check the box next to "open link in new window."

    Choose "post url" to get the attachment page discussed above.

    WordPress remembers which setting you used the last time, so unless you change from one option to another, you will only have to make the choice once.

    (again, apology for trying to multi-task)

  7. Dear 1tess, don't blush unless it becomes you. I knew about the "images" reference already - I referred to it in the last thing I wrote here above. I had just not known or wondered about that "none - fileURL - post URL" selection until you mentioned it, and you know what? When you pointed out that choice I suddenly understand what the Gallery is all about: To show the picture in full size for those who want to see that. (I wish that the Support page had said just that...)

    I have my pictures already reduced when I publish them so they can never be enlarged. So I am now going to change all to "none" - I tried it and it works, the picture becomes non-clickable.

    Now a last favor from you, and then I'll shut up: Is there an alternative to manually changing that form to "none" for each one of my hundreds of already inserted pictures without having to delete and upload all of them again with the "none" on the form?

  8. @gymbrat

    OH. There is not an automatic method, but there is no need to delete and re-upload your images.

    The image editor has been messed up for a while and still acts oddly. That makes things a bit more difficult.

    Edit your posts, one by one. click a picture, select the mountain icon, and that will get you to a pop up image editor. Select "none."

    This is where the image editor is causing trouble: it resizes your picture to its full size.

    If your pictures are uploaded at the size you wanted them to appear in posts, then no problems here for you.

    But if your uploaded image is larger, then you must go to "Advanced" and type in the the desired width, and delete info from height.

    Then update.
    Repeat for each image…

  9. Perfect! I tried it and it works! This will be easy. Thank you, thank you, you have really helped me, 1tess!

    If the support references had included a little of what you have told me, then other "beginners" would know what to do without having to ask. Just a sentence or two about the PURPOSE of using galleries, and about the result of using the "none" vs. "file URL" selection. And also about the use of the "mountain" icon. Thus a bit more of "why" and not only "how".

    But that is for the big guys to decide. You helped me one-on-one, and for that I am most grateful, 1tess. Thank you!

  10. Happy to help!
    Tess

  11. Thank you 1tess, this thread has clarified some questions that I had about the new ways that images are being displayed. I tried to change some of my settings in existing posts from "post url" to "file url," but after I save the changes, the setting goes right back to "post." Does this mean that I have to delete and re-upload if I REALLY want the settings changed? TIA

  12. @buyathread

    Can you post a link ( http:// ??) to an article of yours where you tried to change the settings from "post url" to "file url"?

    In addition, even very good would be a link to a post that still links to "post url."

    I don't know why you are having problems, but truly really absolutely totally
    DO NOT DELETE IMAGES FROM YOUR LIBRARY! bad: that will cause you to do a lot of unneeded trouble and work!

  13. Well, I'll be damned, it DID work! I tried -- and seemed to have succeeded -- in changing the settings on the three images within this post:

    http://buyathread.wordpress.com/2009/11/22/2009-weave-of-the-week-43-mexican-tablecloth/

    even though the setting itself didn't seem to change. Go figure.

    (Didn't know that it is a totally bad idea to delete images from my library, but thanks for the warning.)

    Thanks so much for the help, as always.

    PS I learned how to make my own watermark (on the cat image in this post) with photoshop, thanks to a forum comment that was made by panaghiotisadam, so thanks to him too.

    The forum rocks!

  14. I just looked at your post, and noticed that the large picture has a bad link:
    404
    http://buyathread.wordpress.com/2009/11/22/test/tablecloth-lg/
    Perhaps if you delete it from the post (not from the library), then re-insert it, that might fix the problem.

    (If you delete pictures from your library, then pictures in your posts won't be linked to anything: they will disappear from your posts)

  15. Thanks, 1tess, will do.

  16. I looked at the large tablecloth pic with two browsers and it looked fine (shrug), but I tried to change the post-to-file settings on another post, and this time it really didn't work.

    http://buyathread.wordpress.com/2009/11/01/2009-weave-of-the-week-42-haitian-sequined-banners-drapo/

Topic Closed

This topic has been closed to new replies.

About this Topic