Need help? Check out our Support site, then


Please do not delete XML from my [sourcecode language='xml'] portions

  1. See http://en.forums.wordpress.com/topic/please-stop-deleting-the-xml-from-my-sourcecode-languagexml-1

    Please get back to me on this, as it is very irritating that WordPress kills all but the most basic XML from sourcecode language=xml fragments.

    --jeroen
    Blog url: http://wiert.me

  2. Can you please give us a link to a post or page where this isn't working?

  3. Any new post that I try to do with the WordPress "HTML" markup that contains a correctly tagged sourcecode XML block consistently fails.

    Example post is in http://wiert.files.wordpress.com/2012/02/wordpress-html.doc

    Please follow the link in my opening post to get a feel for what I already know.

    --jeroen

  4. Is the example included at the bottom of your .doc file what you were trying to post?

  5. @jpluimers: I checked the file that you reference and the reason why it's not posting correctly is because of a spelling error, your code snippet should start with "sourcecode" (currently it starts with "sourececode"). Once you correct that typo, the code snippet works ;)

  6. that was a typo, but this post isn;t, and all of the XML but the first line is gone: http://wiert.me/2012/07/31/generating-wordpress-posting-categories-part-1/

    That is consistent (just search my blog for XML http://wiert.me/category/development/xmlxsd/xml/

    You will see that almost all XML is gone. I even went so far as to replace less than and greater than with braces (but that looks so odd that I stopped with that too).

    --jeroen

  7. Had the XML appeared properly in the past?

  8. Ok, so this has happened since you first started posting XML, it wasn't a recent development?

    If it was recent, do you know about when it started?

  9. I have no idea when it started, it has been there all the time and needs to be fixed.

  10. I have no idea when it started, it has been there all the time and needs to be fixed.

    Can you save a post draft with the XML source code using the Text editor, making sure not to switch to the Visual Editor, then reply to this forum thread so I can try to reproduce this on my end?

  11. For instance this post:

    http://wiert.me/2012/07/31/generating-wordpress-posting-categories-part-1/

    it has two XML parts that got truncated, that you can download here: http://pastebin.com/b6Z0v14E
    and here: http://pastebin.com/mkY1icLB

    And this post:

    http://wiert.me/2012/05/23/the-ado-net-entity-framework-and-sql-server-2000-the-providermanifesttoken-attribute-and-selecting-it-with-xpath/

    for which the XML is here: http://pastebin.com/HdSuzfH0

    Note that it has to do with the visual editor, but it is virtually impossible to avoid the visual editor as the text editor does not support keyboard shortcuts for editing links, formatting, etc.

  12. Hi,

    Thanks for replying with the Pastebin examples. I tried the first one in a test post in the Text editor, then previewed the post successfully (in a new browser tab).

    Next, on the Edit Post screen, I switched to the Visual editor (screenshot), then previewed the post again, and the result was still the same (screenshot).

    Can you make sure that in the shortcode language option that you're enclosing the "xml" syntax in double quotes? I've annotated it in the first screenshot.

  13. I re-edited the post and now it works.

    Something must have changed, just check out the revisions (see below).

    This is the text now: http://farm9.staticflickr.com/8291/7863569690_35b78a7b97_o.png
    This is the visual now:
    http://farm9.staticflickr.com/8445/7863603600_802e674c93_o.png
    This is the published page now: http://farm9.staticflickr.com/8308/7863570324_49361ee0e1_o.png

    This is the revision list: 20120824 clearly broke it again: http://farm8.staticflickr.com/7264/7863570066_84b70337c2_o.png

    This is the broken copy: http://farm8.staticflickr.com/7132/7863615394_69388b13ee_o.png
    This was the OK copy from the text editor on 20120824: http://farm9.staticflickr.com/8434/7863673170_6c408d44f8_o.png
    This is part of the diff (it also mangled with the html on the same page):
    http://farm8.staticflickr.com/7247/7863673354_3379a852c5_o.png

    The odd thing is: today I did the same actions as 20120824, and now it works. Very strange: something must have changed somewhere.

    --jeroen

  14. I'm glad to hear that it works! I'll go ahead and mark this as resolved.

    We deploy updates to WordPress.com many times daily, so it's tough to say what might've happened without more details to investigate.

    If you come across this again in the future, please post here again (or in a new forum thread) to let us know the exact steps you're taking so we can try to reproduce it on our end.

  15. Thanks, will do.
    Any place I can see which updates have been applied to WordPress.com?
    And: any chance for a response on the keyboard focus issue here: http://en.forums.wordpress.com/topic/please-restore-the-tab-order-the-way-it-worked-2-weeks-ago?replies=1#post-986198
    Thanks again!
    --jeroen

  16. We typically don't announce minor updates, as those happen several times per day, but you can always read about major updates at http://en.blog.wordpress.com/

    As for the other thread, we're looking into it.

  17. thanks, that blog is on my roll now.

  18. Sounds good — cheers Jeroen! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic