Need help? Check out our Support site, then


Please give me back my Alt-Shift keyboard shortcuts

  1. Dear @wordpressdotcom,

    Don't steal my Alt keyboard shortcuts and revert to Alt-Shift shortcuts.
    You are breaking all my browsers GUIs!

    For eons, Alt-Shift-d was "strike through".
    Recently you changed this to Alt-d, disabling the browser's existing Alt-d (which for most Windows browsers is to "put the focus to the address bar").

    You violate the nr 1 UI rule: don't mess with existing shortcuts.
    As a paying customer, I expect you to keep basic things like these working.
    So please revert them back ASAP.

    --jeroen

    The blog I need help with is wiert.me.

  2. russelrayphotos
    Member

    It's not just the keyboard shortcuts.

    A couple of days ago they changed the HTML tab to a TEXT tab. Ever since then keyboard shortcuts have been all messed up as well as many of the what-had-been standard HTML formatting codes.

    As an example, previously I could click on a bullet and each time I hit Enter for a new line, I'd get a new bullet line. Not anymore. Now every line is under just one bullet until I unclick the bullet.

    Frustrating.

    Also, I think you need to edit something in your title and/or the first two lines of your post. You title wants your Al-Shift keyboard shortcuts back, but your first line says you want your Alt shortcuts back.

  3. Thanks. I know see why title and first lines are confusing (:

    WordPress.com now steals the Windows Alt shortcuts.
    I want back the WordPress.com Alt-Shift shortcuts.

    And not so nice to learn the HTML (now text) is messed up too. Thanks for warning me on that.

  4. wordpress wtf?!
    I use polish and I'm not able to use our special letters. I CAN'T WORK! :(

  5. Cmon, i'm brazilian! I use a macbook and the shortcut for "ç" is the same for "align center" (alt+C). It's really annoying, I can't write anymore!

  6. I'm so sorry this is happening to you people. This thread is flagged for Staff attention and there's no more that I can do for you.

  7. This so much sounds that WordPress is aimed at English users only.

    Knock knock. The world is 7 billion people, of which more than 6.5 live outside the USA, and only max 1.2 billion speak English.
    (http://en.wikipedia.org/wiki/English_language)

    That is a total mismatch with the WordPress jobs "born in Texas" motto: http://automattic.com/work-with-us/

  8. Ok, is there any workaround other than copypasting from text editor?

  9. Thanks, everyone, for reporting this issue. The technical change that caused this problem has been reverted back to the way it was previously, so this behavior should no longer be happening. If you're still having any issues, please let us know.

    We apologize for the inconvenience!

  10. thanks!

  11. Thanks so much!

  12. So anyway I still have this problem (just now I tried to write Polish letters and it changes only the toolbar: smaller/bigger). The problem seems to be in Firefox, not in G Chrome.

  13. swiatnacho - thanks for letting us know, I'll inform the team and get back to you.

  14. @swiatnacho: could you please clarify which shortcuts you are using that create that effect? And which toolbar becomes smaller/bigger - the WordPress.com one, or another one?

  15. Great, thanks!

    Now please also fix the bug that deletes valid XML from posts.

    See for instance here: http://wiert.me/2012/02/23/wordpress-xml-sourcecode-help-needed-forum-posts-gets-deleted/

    That bug is way overdue.

  16. Hello Jenia,
    Example: I use alt+z to have Polish "ż". It worked before. Now, the toolbar when I write new text is smaller. I made a photo:

    To have special Polish letters we use:
    alt+ z, alt+ x, alt+c, alt + e, alt + s, alt + l, alt + o, alt +a, alt +n.
    (both small and big).
    I think, we can't have another shortcuts for them.
    Tomek

  17. The same issue here (FF 14.1).
    You basically cannot enter any text with polish programmer keyboard layout (Alt Gr + letter combination).

  18. Thanks for the additional information. It's possible that your Visual Editor is using a cached copy of the code - would you mind clearing your browser cache to make sure that's not the culprit and let us nkow?

  19. @jpluimers: I replied to your original question about posting XML source code here. To avoid confusion between multiple thread topics, please post any further questions or feedback in that thread -- thanks!

  20. Hi again,
    @kathrynwp, I cleared the cache without effect.
    All the time, we have problem with shortcuts.
    That's my screenshot (with additional info):
    http://swiatnacho.files.wordpress.com/2012/08/focus.jpg

    So, I have even help-balloons with false shortcuts.
    Tomek

  21. @swiatnacho: I am sorry you are still having trouble with this. I was not able to replicate what you are describing on a Firefox on Mac. Could you please try the "long" shortcuts, e.g. type Ctrl + Alt + u, Ctrl + Alt + o, Ctrl + Alt + z to trigger the shortcuts and then try again to see if Alt + z pulls up the special character then?

  22. I am so relieved this now makes sense. It was a horrible day trying to use my Romanian keyboard and not understanding why WordPress is messed up. I'm using Firefox. Whilst Right Alt + [any key] works for my Romanian letters, when in the Post page it doesn't.

    When writing a post with Romanian letters, the following combinations do not work anymore:

    Right Alt Tab + A for letter ă
    Right Alt Tab + Q for letter â
    Right Alt Tab + S for letter ș
    Right Alt Tab + T for letter ț
    Right Alt Tab + I for letter î
    Right Alt Tab + E for letter € (Euro symbol)

    It's sooo frustrating.
    At the time of writing this message, the problem still exists.

  23. @jenia:
    1. I use Firefox on Windows 7 (not Mac)
    2. I tried your method - no effect
    3. I tried also to change interface language to English and then back to Polish. Finally no effect.

  24. @jenia
    Are you sure you got polish programmer keyboard layout installed on your PC? You have to install it to replicate the problem. Use right alt to try to enter the chars.

    Here's screenshot from Win7 how this looks line in control panel:
    Screenshot

  25. I got Polish programmer keyboard since years (nothing changed), I always use the right ALT and I HAVE COMPLETELY NO PROBLEMS inserting Polish letters everywhere except of WordPress visual dashboard since a week or two (after wordpress - not me - made changes. Even entering text in text mode is ok.

  26. @moromitic, @swiatnacho, @digitalmb2b: thanks for the additional information, we are looking into this.

  27. hi, Ive got the same problem with my polish letters. I had no problems with using right ALT+a, z,l,c s,x,e and now I do. the WP skin is not new (Ive been using it since about a year and there was no problem with letters). whats weird - Im able to write them in my topic, but not in the text window. and - here I can write`em too: ą, ż, ć. tricky, very tricky. what else should I check? I cleared my cookies. thank you

  28. Same thing here too. Some time ago there was no problem, then wp changed something, making alt+a a shortcut. After the change was reverted it is only worse than before. More our polish STANDARD shortcuts were used for something else - mostly for roll/unroll the editor's tab in wp editor... I know that I can write all I want in notepad, but it is not the solution, why we, as poles, can't use normal editor like before... Pls, do sth about it.

    I was writing about the problem here.

  29. Hello,
    I can't use the polish special caratter any more, careters like śąąęąć,. All pc settings are ok, I can use caretters on word, on another web pages (mail, chats etc.).
    When I tray to whrite ą, normaly I make a+alt gr.

Topic Closed

This topic has been closed to new replies.

About this Topic