Need help? Check out our Support site, then


Please stop deleting the XML from my [sourcecode language='xml']

  1. Somehow my previous post immediately got cosed, so here is the question: http://wiert.me/2012/02/23/wordpress-xml-sourcecode-help-needed-forum-posts-gets-deleted/

    Please read it and answer on the forum or by email.

    The blog I need help with is wiert.me.

  2. This is the WordPress.com peer support forum and we Volunteers do not provide email support. Please use the Help link on the top right hand corner of your Admin page to contact Staff. related link: posting source code

  3. @timethief thanks. will do.
    I know about the sourcecode tag, see my blog posts here: http://wiert.me/tag/sourcecode-language/ but thanks for mentioning the link, others will surely benefit from it.
    --jeroen

  4. Understood. :)

  5. This happens to me too. As I can't reply to the newer support question, I'll do so here. It appears to occur only in visual editor mode. I can edit a document in HTML mode and put in XSLT samples e.g.

    [sourcecode language="xml"]
    <xsl:template><p>test</p></xsl:template>
    [/sourcecode]

    And save it fine. But if I accidentally switch to Visual mode the XSL elements will be stripped but the HTML elements remain. I'm guessing this has something to do with a filter that fixes invalid HTML. There is an option in Writing called "WordPress should correct invalidly nested XHTML automatically". But in my case that's currently disabled.

  6. NEVER, EVER put shortcodes into the visual editor. It is supposed to pick them up and correctly render them when entered in the Visual editor, but it seldom does in my experience.

    Always use shortcodes in the HTML tab. 99% of the time you won't have any issues if you do.

  7. I agree, but the problem is that even *viewing* them in the Visual editor will change them. And the Visual editor will be the default when you open it, if that's what you were using last time you edited a post. So the only way to avoid corruption in the 1% of your posts that include XML is to NEVER, EVER use the Visual editor for the other 99% of your posts either. :p (Or at least remember to open an unrelated post first, set the editor to HTML mode, then open the XML post for editing...)

  8. Another "feature" of wordpress.com it would seem.

    Fire some shots across the bow of support and see if they will fix things. It might be an issue with the editor itself, in which case they will have to file a bug report with Moxiecode, the authors of the TinyMCE editor and then wait for them to fix it.

  9. I'm ALWAYS using the HTML editor for sourcecode as it NEVER works in the visual editor. But: I do verify the results in the VISUAL editor.

    I didn't know about the switch from HTML to VISUAL and back could corrupt it.
    Will try that for my next XML based post.

    Note: even in the HTML editor, XML will fail 95% of the times in the HTML editor.

    Will keep you guys posted.

    --jeroen

Topic Closed

This topic has been closed to new replies.

About this Topic