Need help? Check out our Support site, then


Podcast Epsiode Titles Shown Incorrectly

  1. Hi All,

    I am having issues with my podcast titles not showing correctly.
    My feed i am using for the podcast is (http://tpsuk.wordpress.com/category/podcast/feed/)

    When searching for the podcast on the iPhone Podcast app is displays everything correctly, episode titles and details, but as soon as i subscribe and view the episodes in library the epsiode titles are all the same, the name of all the episodes are 'tpsuk'

    I checked my feed, it appears that the app is looking at the Media Title tag to get the episode title.

    Extract from feed
    <media:title type="html">tpsuk</media:title>

    the 'tpsuk' is what all my epiosdes are being called.

    I was wondering if anyone has seen or come across this issue and how to deal with it, i have played around with feedburner settings but no joy

    Any help would be great
    Regards
    Alan

    Feedburner: Feeds.feedburner.com/tpsuk

    The blog I need help with is tpsuk.wordpress.com.

  2. Hi,

    This exact problem is happening to me! What I noticed was that the iPhone podcast app was listing my episodes as my email address that I'd put for email alerts. I created a new email address so it at least was the name of the show (out of the canon), but it is very annoying. I emailed Apple Support and the said: "we cannot specifically determine the cause of the issue". They suggested I report a concern through iTunes... but that's no use as none of those subheads cover a technical problem like this.

    Sorry to be no help, but it is slightly comforting to know I'm not the only one. What do we do now?

    Outofthecanon.wordpress.com

  3. Outofthecanon - Thanks for replying, glad to hear I am not the only one too, I am starting to wonder if this is just a glitch with the App, but then I can't see why every other podcast that I am subscribed to displays correctly.

    But you have a point about the username, as my username for the blog is tpsuk and this is what is being displayed.
    So maybe this is wordpress issue and it's passing the blog username incorrectly, i was kind of hoping that wordpress support may get back to us

  4. I have flagged this thread for Staff assistance.

  5. Thanks timetheif, hopefully we will hear something soon.

    If the staff require anymore information to assist their investigation, i am more then willing to help

    Thanks

  6. Since the issue isn't reproducible in other podcast apps or iTunes, I recommend reporting this issue to Apple through: https://discussions.apple.com/community/app_store/podcasts_for_ios

    Sorry for the inconvenience.

  7. Did you guys found any solution for this? I'm having the problem in my show that is hosted at WordPress.com, but the one hosted in a WordPress.org is fine. Both have the exact same configuration in feedburner and only the one in wp.com is wrong :-(

  8. I got in touch with Apple and they looked at my XML feed and said that the Apple app is picking up an extraneous tag in my RSS feed (from WordPress, so it is a problem stemming here).

    They sent me an example of the code for my episode 7... in line 52 there is this tag: <media:title>.

    She said if that tag was removed then the problem would be resolved.

    But I can't figure out how to get to the XML code on WordPress. In fact, I suspect it's not allowed... am I right. It seems like an easy fix though, if I can access my XML code.

    Any thoughts?

  9. Ahhh... wait. I think I might have cracked it. I can access the XML code through my Feedburner account... I can see the offending tag in all the lines of code.

    I will now try amending the code on one of the episodes to see if it works. I will keep you guys updated...

  10. Ahhh... wait. I think I might have cracked it. I can access the XML code through my Feedburner account... I can see the offending tag in all the lines of code.

    I will now try amending the code on one of the episodes to see if it works. I will keep you guys updated...

    Did you have any joy?, i don't think on WordPress.com we can edit our feed or on feedburner

    Can this be Bumped for staff attention again please, these latest info provided by outofthecanon need looking at

  11. No luck!... The Feedburner XML feed is un-editable... So even though I can see the dodgy code I can't change it.

    It's being pulled from our WordPress.com sites, so it would have to be changed here I guess. Apple aren't going to change how their app works for a few folk like us, are they? There must be some way for someone (an admin?) to make this small tweak to our WordPress code?

    If that fails, I am testing a completely fresh (test) podcast through Tumblr to see if that has any problems. If that works, I suppose I'll have to migrate my blog and posts over there, and have listeners resubscribe.

  12. Hi all,

    When I check the feed, I see different MP3 titles. I do apologize if this isn't quite what you're referring to, and I welcome you to send me a screenshot that shows the error.

    In the meantime, Outofthecanon, while I would rather you not leave us, of course, if you get a custom domain for your site you can move that custom domain and your listeners won't have to resubscribe. Of course, you'd have to get them used to coming to your new custom domain (your WordPress.com site would automatically redirect, but you'd want them to be used to the new domain so you can transfer them seamlessly first).

    Does that make sense? And I appreciate any links to screenshots so I can investigate the issue further.

    Cheers!

  13. Hi Zandyring,

    Thanks for coming back to this one, regarding the different MP3 titles, this is correct and are links to where the MP3 files are held, however in every post in the feed, a few lines under the MP3 file name is a tag <Media:title type="html">

    Example
    <media:title type="html">tpsuk</media:title>

    In-fact the above tag shows up twice per episode/Post in the feed

    Now it seems that this tag is being used for every episode name of my podcast (All my epiosdes are called 'tpsuk') when i think it should be using the <title> tag

    Example:
    <title>082 TpSUK: Platinum Episode</title>

    Below is an extract from my feed and i have made bold the mentioned tags

    <enclosure url="http://dl.dropbox.com/u/9506991/TpSUK/81-90/Episode84/084-MerryEffinChristmas.mp3" length="46655517" type="audio/mpeg"/>
    <enclosure url="http://dl.dropbox.com/u/9506991/TpSUK/81-90/Episode84/084-MerryEffinChristmas.mp3" length="46655517" type="audio/mpeg"/>
    <media:thumbnail url="http://tpsuk.files.wordpress.com/2012/09/0051.jpg?w=147"/>
    <media:content url="http://tpsuk.files.wordpress.com/2012/09/0051.jpg?w=147" medium="image">
    <media:title type="html">tpsuk</media:title>
    </media:content>
    <media:content url="http://1.gravatar.com/avatar/d94c3b4e12447dcc4a2eaed3d06ec316?s=96&d=monsterid&r=PG" medium="image">
    <media:title type="html">tpsuk</media:title>
    </media:content>

  14. The problem tpsuk is reporting happens here too! My feed is OK everywhere, except in Apple Podcast App. My feed is even OK in iTunes and in any other podcatcher.

  15. Thanks for the clarification!

    I'll see what we can dig up on this.

    I'll keep you in the loop!

  16. Hi Guys,

    Any update on this problem yet?

  17. Hi - sorry for the really slow response. I haven't gotten an answer yet, so I reminded the internal team of the issue. Thanks for the reminder :)

  18. Hi again! One of our internal folks just got back to me (the reminder did the trick!) - so it turns out that this is working as designed... it's pulling the title for images, not incorrectly naming the podcast.

    It looks at the HTML for the post and looks for all the Images and then sets the title based on the tags that appear in the generated HTML giving priority to the title attribute over the alt attribute.

    In the post here the IMG has an alt tag of ‘tpsuk’ and that is used.

    The gravatar image gets your username as the title.

    So you could go through and make sure that your images are named descriptively for the posts, or leave it as-is.

    I hope that helps!

  19. zandyring, I'm sorry, but I didn't understand your answer...

    My podcast posts use to have imagens inside them and once I noticed what you just described I removed them all. And also as described by you now I get all my episodes named after my Gravatar user name, that is "vladcampos". Hera are my podcast episodes if you wish to take a look: http://vladcampos.com/category/podcast

    What I don't get is why you are telling us this is the correct behaviour. It doesn't make any sens. If we are creating a podcast feed (audio/video) why is the system grabbing names from images?

  20. The Gravatar is linked to my wordpress profile, not my blog post
    In fact when i first started looking at this issue i removed the images from some of my posts and it made no difference to the feed, it still showed 'TpSUK' for my posts that i changed, Same as Vladcampos.

    Why is the Gravatar details even in my rss feed, i get that it uses the images i post in my blog, but why my gravatar?

  21. In my opinion, it is clearly a issu between WP dot com and Apple Podcasts App. My feed works perfectly well everywhere else. But blame Apple is kind of no sense too since I have another podcast in a WP dot org blog that woks perfectly well with Apple podcast App. So, maybe the issu is related to the "dot com" WP or even with the audio plug in in use at WP dot com that is different from the on in WP dot org.

  22. This 'solution' makes no sense! I have only one Gravatar image... which is not on any of my posts. If the RSS feed is always taking the Gravatar from my feed, how exactly can I change that so that it gives each of my episodes the correct title? If I change the name of it, it'll just change all the episode titles to the new name. I need the episodes to have the correct individual names!

    I have set up a new test feed on Tumblr and so far the episode names are appearing correctly on the podcast app, and elsewhere. If this can't be sorted behind the scenes, then I suppose I'll have switch to Tumblr.

  23. Agree with outofthecanon here, why is the gravatar information passed through with each post, when it is not required.

    Anyhow, i have now moved my site away from WordPress.com to a selfhosted site, and suprise suprise my podcast episodes are now working a treat --Hooray for me

    Booooo! for wordpress.com - This really needs sorting and can see this getting a more and more popular issue, possibly an option to turn off your gravatar

  24. Hi again,

    Sorry to be vague - I'm asking for additional clarification on this. I'll advise when I have more information - sorry for the delay!

  25. Hi zandyring, anything new about this issue?

  26. Same problem for "Oscar & Martins Podcast" too.

    Often doesn't the shows show up when subscribed. But always shows up in the iTunes Store. So the listeners must manually download them.

  27. ... Our cover photo shows up in the Podcaster App, but not in Computer iTunes? Similar problem?

  28. We're still looking at this - apologies for the delay!

  29. Hi all,
    I'm having a slightly different issue here. I subscribed my wordpress blog to itunes a long time ago. A year ago I needed to change the description and the art work that appears in Itunes store as I changed it on my blog. I contacted apple support and tried everything with them and they said that I have to add some code to my blog’s rss feed. But the problem is that I CAN NOT ACCESS NOR EDIT the rss feed. The following code I copied from the apple support page http://www.apple.com/itunes/podcasts/specs.html#example) is the code i need to add to my feed with modifications off course.
    --------------------------------------------------------------------------------------------
    (<itunes:image href="http://example.com/podcasts/everything/AllAboutEverything.jpg" />)
    (<description>All About Everything is a show about everything. Each week we dive into any subject known to man and talk about it as much as we can. Look for our Podcast in the iTunes Store</description>)
    --------------------------------------------------------------------------------------------

    Where can I add this code and add the info needed for my blog to show properly on itunes store???
    Please it has been a year now since I changed the image and the description and till now can do nothing about it.

    My blog’s url is : http://casa-egypt.com/
    The itunes url is : https://itunes.apple.com/us/podcast/mhtt-kasa-msr-casa-egypt-broadcast/id398177221?mt=2&ign-mpt=uo%3D4

    Thanks is advance
    Dina

  30. We've been looking into the issue of the image/description not showing up, and so far can't find anything on our end that would prevent the image/description from updating and refreshing as intended. We ask that users with this issue check their SmartCast settings with Feedburner and make sure all the information there is accurate, and also make sure that all settings comply with Apple recommendations here:
    http://www.apple.com/itunes/podcasts/specs.html#formattingvideo

Topic Closed

This topic has been closed to new replies.

About this Topic