Need help? Check out our Support site, then


Post to Twitter - not showing any photos

  1. sequinsandcherryblossom
    Member

    When other bloggers post to Twitter they get four photos from their blog shown as a preview, but I don't.

    How do I get it to show the preview photos? I don't have publicise turned on, but then neither does a friend of mine who does get the photo preview.

    I use the Twitter share button on my post to make the tweet.

    The blog I need help with is sequinsandcherryblossom.com.

  2. Have you checked the settings on your Twitter account to be sure you have enabled image display there? Tweet media

  3. sequinsandcherryblossom
    Member

    I'm not sure what you mean. Tweet media is about displaying media with sensitive content - I certainly don't want to do that. I can't find any other settings in Twitter that are to do with turning images on or off.

    I don't have any problem displaying photos on Twitter that I attach myself.

  4. Sorry what I posted was not helpful. Another Volunteer or Staff will be along to assist you.

  5. sequinsandcherryblossom
    Member

    Hi there. It's been a couple of weeks now since Timethief said someone would be along to help. Has anyone got any ideas what the problem is?

  6. sequinsandcherryblossom
    Member

    For the information of others with the same problem, I asked for help over at Twitter. They told me to submit one of my posts for validation through the Twitter Card validator. Once I did this and got approval back, my Twitter posts showed the preview.

    I thought that WordPress had Twitter Cards validated by default, but it seems you need to get the validation yourself.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic