Need help? Check out our Support site, then


Posting to Facebook but no pictures are being shown

  1. I have setup my blog posts to go to facebook but when they are posted the text and links work but I am not getting any pictures posted to facebook. My blog posts normally contain one picture on top. I have tried making that picture a featured pic but no go. Is it possible to have this picture sent to facebook?

    Thanks

    The blog I need help with is assetguru.wordpress.com.

  2. Hello there,
    Please be aware that we cannot control which images if any Facebook uses. We cannot control when they clear their image caches either. See here for more information and instructions.

    Only the first five images uploaded to a post (direct inclusion/gallery/slideshow) will be sent to Facebook. The images size has to be at least 200 x 200 pixels.
    To select which image will be used for things like Facebook Publicize, you can use a theme that supports featured images. If a featured image isn’t set or your theme doesn’t use featured images, then the code tries to pick the first image in the post or page. If no image is found, then the blavatar is used. http://en.support.wordpress.com/publicize/#troubleshooting

  3. Ok. What if we are using a featured image and there is only one image yet no images are used. No other tips to get it to take an image?

  4. No I'm sorry this is the way it is. Facebook has total control over whether or not images are displayed and which ones are displayed -- we have none.

  5. Any suggestions on posting software (3rd party) which will post to both facebook and wordpress which gets images on facebook more often?

  6. I'm sorry I don't have any advice to give you.

  7. Just posting the url of your post directly into a status update works fine. An image comes up.

    Not sure that the publicise feature is that useful, only takes a couple of seconds to post the things manually.

Topic Closed

This topic has been closed to new replies.

About this Topic