Need help? Check out our Support site, then


Posts not visible when using a static page as start

  1. Hi there!

    I changed the start page for my site seagis.org to a static page but all of a sudden my posts are not visible under the "Blogg"-menu at the front page.

    I have tried to find an url for the blogroll in in order to paste it to the box for custom urls in my custom menu but i can´t find the right url as it seems.

    What am I doing wrong? I just wanted to change the starpage to a static page and thought that the blogroll would automatically be visible in the menu.

    http://seagis.org/

    Thans for any help!!
    /Vincent

    The blog I need help with is seagis.org.

  2. Well, you have a choice of a static page OR your blog posts as the landing page. They're completely separate things and you have to choose one or the other.

    The blogroll does not have a URL. It is the Links widget.

  3. Hi!

    Maybe I was not clear enough.. I want the static page to be the landing page AND to keep a title in the menu "blog" where you can read all the posts (as previously on the landing page). Now the title in the menu displays nothing.

    Or even simpler: How/where should I display my blogroll when using a static page as landing page?

    /Vincent

  4. You need to go to Settings > Reading again and set "Blog" as your posts page.

  5. There is no way to put the posts to a certain page in the settings, as far as I can see.

    ??

  6. @sea63gis
    There is only one running page for posts in a blog. By default it is the front page of the blog but you can change it to another page. If you do not want all the posts to show on the front page then you can create a static front page for your site and a “blog” page for posts to display on.

    Choice 1 static front page.
    Choice 2 running page for all posts on front page.

    Which do you choose? It’s one or the other.

    If you choose Choice 1 static front page then you have to create two pages. One for the static front page which you can call anything you choose example “Welcome”, and one for the blog posts to appear on which you can call anything you choose example “Blog”. After you create those 2 pages you go here > Settings > Reading and make the designation change and click “save changes”. http://en.support.wordpress.com/pages/front-page/

  7. @timethief thanks,

    I have earlier creted several pages and wish now to display one of them as the start page, instead of the latest posts. The problem is that my blogposts does not appear in the domainname/blog (or in any) page after making the proper changes in the settings you described. I see no way of how to steer where my blogposts should appear as they disappear when I change the settings.

    Is the problem that I had several pages before I made the change? I have also created an empty page for the posts to appear in, as described in the tutorial.

    In my theme (Pool) the blogposts normally appear in the menu bar under a "start"-link, which has the domain name as url. Under Display > Menus this is the only menu item with an editable url. I also tried to change this url to be the url for the new empty page but witout success.

    This seems to be really easy on paper, but does not work for me for some reason :-(

    Thanks for helping!

Topic Closed

This topic has been closed to new replies.

About this Topic