Need help? Check out our Support site, then


Posts opening as new pages

  1. How do I stop my posts from opening up in new pages? Also, going through my old film reviews on pnabarro.wordpress.com I want to re-edit the posts so they don't open in a new page. Please help.

    The blog I need help with is pnabarro.wordpress.com.

  2. That's not possible. Our posts are only "showcased" on the main page for posts on our blogs. When the title links or the comments links are clicked the posts open on their own pages.

  3. Are you clear of the differences between pages and posts? http://en.support.wordpress.com/post-vs-page/
    Do you need help with creating a custom menu? There are many common errors, misunderstanding and misconceptions when creating custom menus and you can read about them here > http://wpbtips.wordpress.com/2011/12/19/custom-menus/

  4. Hi - yes I understand the difference between posts and pages. What I do not understand is why my film reviews (links on a page), some open in a new window, some don't?-...Any ideas, because I don't want any of them to open up in new windows....

  5. Did you copy and paste the links from elsewhere into your film reviews page? Or did your actually create them from scratch in the WordPress.com editor? I'm asking because when you create them from scratch there's an option you can select to open the links in another window.

    This is guide for creating links in blog posts and pages and it does sound like you are following it.
    http://en.support.wordpress.com/links/
    This is the general link model:
    <a href="URL HERE">Highlighted anchor text here</a>
    This is the visual result but as it's just an example it's not actually linked to a page:
    Highlighted anchor text here

    Enter the anchor text you want to link to first.
    Then use your mouse to highlight that anchor text.
    Next click the chain icon in the Visual editor and proceed to create the link. (Select the option to open in new window if that's what you want.)

  6. Hi - for the last year I have been doing that. Posting new film reviews without ticking opening the link in another window. Unfortunately, a lot of my older reviews/posts ticked that option, so I was wondering how to reverse that?

  7. I don't know of any way to do this other than by editing the links. So you understand what you have to deleted form the links note this please:
    <a href="URL HERE" target="_blank">TEXT HERE</a>
    It's the
    target=”_blank”
    that compels the links to open in a new window.

  8. gorgewildphoto
    Member

    The "open link in new window" box for me doesn't work. I can click it or not click it but the links behave how they want. It's like someone is coming along behind me and changing the setting. If I have to manually fix the code, why is there a checkbox at all? It's very frustrating because I for one want to control where my audience is directed to-- do I want them to have two tabs or windows open so that my blog stays up on their screen? Or do I want them to proceed to another site?
    If I had tons of time, whatever, make me do it manually but like many others, I'm trying to get the blog post created as fast as possible, which means as few steps as possible. That non-working checkbox is a real deal-killer!

  9. @gorgewildphoto
    That's extremely odd because I can use that box when I use:
    IE8, Firefox 17 and Chrome 23 on my own computer, on my husband's computer and on our company computer too.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

  10. @pjnabarro: to add to @timethief's suggestion, you could search all posts (under Posts > All Posts in your Dashboard) for the term target="_blank". Then, open each impacted post individually, switch over to Text editor, search for the same text, delete and save the changes.

  11. @gorgewildphoto: that sounds very strange, that you checking the "open the link in a new window/tab" setting does not take. Could you please give me a link to a post where it is happening? Also, what browser and which version are you using? I would like to try to reproduce the issue so that it can be resolved for you.

  12. Hi Timethief

    A belated thanks for your input.

    How do I edit the links? I really need a fool-proof guide here. I cannot locate anywhere a link that offers me the opportunity to delete: target=”_blank”

    I try re-opening the post and editing in 'text' format, but there's no instance of the bit you're telling me to delete!! Very frustrating. I don't understand why if wordpress.com offers me the opportunity to "open link as a new page" at the point of creation, why that option doesn't remain to untick?!! Baffling...

  13. @pjnabarro: would you like to give me a link to a post where you wish to change the linking behavior, and I can walk you through an example?

    There are two ways to edit existing links. When you are editing a post in the "Visual" mode, you can put your cursor to where the link is, click the "Link" icon, then unstick the option to open in the new window/tab. Or, you can switch to the "Text" editor and edit the HTML code as @timethief suggested.

  14. Hi Jenia

    Here's a link to the first review in my site.

    PS - Neither of those options you have suggested work for me. In "visual mode", all I get is a 'permalink' where I can edit the name of the link, but there's no option to untick the open post in current/new window tab. I simply cannot see what you are talking about.

    As for the "text mode" -the instructions the other person sent again don't cohere to what I see. It simply isn't possible to delete those instructions, because they don't exist.

    Is it maybe because I have an older form of wordpress.com or a different theme?

    Patrick

  15. Hi Patrick, just to clarify, I work in support for WordPress.com. I visited the post that you linked to: http://pnabarro.wordpress.com/2010/08/23/about-a-boy/ and the post itself does not contain any external links. Timethief, Kris, and myself have been referring to the links you insert in the posts themselves, like shown in the screenshots: http://en.support.wordpress.com/links/#creating-links

    It seems to me that you are referring to something else. Are you clicking on the links in the sidebar, e.g. Category names like "African Cinema", "Animation", "Articles"? For those kinds of links, you cannot set whether they should open in a separate tab/window or not, this is something up to the user actions or browser settings.

Topic Closed

This topic has been closed to new replies.

About this Topic