Need help? Check out our Support site, then


Press this posting to wrong blog.

  1. I have two blogs, one is hidden. When I click Press this to share a link, my draft post displays the hidden blog name at the top, even though the correct/visible blog is selected from the Blog drop-down list. When I save a draft, it is also saved as part of the wrong/hidden blog.

    Can anyone please help with this?

    The blog I need help with is londonstorycircle.wordpress.com.

  2. Hi there - Press This is per-blog, so you'll want to delete that Press This link, and then go to Tools->Available Tools in the Dashboard of the correct blog, and drag the Press This there to your bookmarks.

  3. Thanks very much! That works, but I'm wondering why the "press this" button on other blogger's posts still goes to the wrong blog. I could just always use the "press this" button from my bookmarks, but it would be nice to use the one embedded in blog posts as well.

    Thanks again!

  4. Hi Gigi - When you click the button, you'll notice a dropdown menu to the right of the editor in the Press This pop-up. You can select whatever blog you want to press it to from that menu. I think it defaults to the first blog in your list, but you can choose any. :)

  5. Hi, yes, I know. I am selecting the correct blog, but it's still going to the inactive one (actually, the inactive one isn't even an option to select in the blog drop-down). This may be a bug you should be aware of. However, I'm glad there's the other way that works (bookmarks "press this").

  6. Hi Gigi - Hmm, I tried this out and it posts to the blog I picked from the menu. I am also using Chrome v. 31. Could you please provide a couple of screenshots of this - you using Press This and choosing a certain blog from the dropdown, and then link me to the post published on the incorrect blog, so I can take a look?

    Here are instructions for how to make a screenshot: http://en.support.wordpress.com/make-a-screenshot/

    You can upload it to your blog's Media Library and I can look at it there.

  7. Hi there! Here's a link to the screenshot: http://wp.me/a42J0F-3h

    The link houseofgigi.wordpress.com goes to a hidden blog called "Gigi's Mirror". The blog I wanted to post to is londonstorycircle.wordpress.com. As you can see from the screenshot, it's selected in the "BLOG" drop-down, and there's no other choice.

    However, when I click PUBLISH, it's published to the wrong blog (Gigi's Mirror). Here's the link: http://houseofgigi.wordpress.com/2013/12/02/press-this-test/

    I'm hoping you can see it without my having to make the blog visible. But let me know if you'd like me to unhide it.

    Thanks, Gigi

  8. Hi Gigi - Well, this is weird. I tried to share that post, too, and the same thing happened to me. But it hasn't happened to me when I share from other blogs. Have you used the Press This button on posts on any other blogs and had the same issue?

  9. Yes, it looks like it's happening on any blog I try it with.

  10. Hi Gigi - Well, now it's happening for me on all blogs, too, so I've opened a bug report for this issue. In the meantime, double-check that the Primary Blog in Users->Personal Settings here is your current public blog: https://londonstorycircle.wordpress.com/wp-admin/users.php?page=grofiles-user-settings

  11. Hi, thanks! Yes, my primary blog is set correctly. Happy bug fixing!
    :-)

Topic Closed

This topic has been closed to new replies.

About this Topic