Need help? Check out our Support site, then


"Preview" and "Save Draft" Don't Function After Upgrading Safari

  1. I am using Mac OS X 10.6.8. The other day a prompt appeared when I logged into my blog saying, "You're using an out-dated version of Safari browser. Upgrade to the latest version." I upgraded as instructed. Now, when I change anything in a draft of a post, the "Preview" button does nothing, and the "Save Draft" goes into an endless loop. Now what do I do?

    The blog I need help with is domanidave.wordpress.com.

  2. That's rather odd. :(

    Coincidentally, I was working on a long draft last night, saving and previewing several times, all under Safari 5.1.

    I'd like to rule-out an issue specific to your browser. Would you mind trying again with Chrome or Firefox?

    http://www.google.com/chrome/
    http://www.mozilla.com/en-US/firefox/

  3. It turns out to be browser-specific, as Chrome exhibits neither of the problems.
    Question is still, 'now what do I do'?
    Wordpress said update Safari, which I obediently did.
    Now this updated version of Safari makes my posting procedure buggy.

  4. I'm having similar problems with the latest version of safari.
    Edit a post then preview changes.
    Close the changed view and go back to the post to press 'update'
    Update button shows progress circle and then freezes.
    No revision is saved.
    REALLY frustrating as a) subscribers keep getting update messages each time and b) posting anything but a simple post is too time consuming.
    Consequently, I've given up on using Safari and wordpress.
    Use firefox now.

  5. thesacredpath
    Staff

    I'm using Safari 5.1 on a MacBook Pro with Snow Leopard and have zero problems with any dashboard functions, or anything for that matter. Everything works just like it should and just like it did before I upgraded. (Even the backend of Drupal is now working smoothly.)

    Make sure you are using the latest version of Adobe Flash http://www.adobe.com/products/flashplayer/

    In your preferences under the security tab, make sure java and javascript are enabled.

    Go to System Preferences > Software Update and make sure that your entire system is up to date.

  6. This is a complete pain in the "A..". I've experienced this repeatedly today. I'm having the exact same problems as domanidave.

  7. Thanks for tips thesacredpath.
    I've done all of that but continue to have the same problem.
    No issues with other browsers.

  8. This is definitely a Webkit bug, affecting both Safari and Chrome, so we'll have to wait for them to fix it. There's nothing that we can do on this end.

    https://bugs.webkit.org/show_bug.cgi?id=28633

  9. Hmmm... I can't get Chrome to misbehave in the same way Safari does. Fortunately I'm not 'married' to Safari. Thanks for your help!

  10. You're welcome!

  11. I am so glad to finally find this forum!

    I was going crazy trying to save and preview after updating to Safari 5.1 on Snow Leopard, and then not getting replies to my emails from WordPress support.

    Will try using Foxfire or Chrome, thanks!

  12. Hi, I ran into this problem today, and discovered a workaround that works for me (Safari 5.1, OSX 10.6.8).

    The problem was occurring for me when I had Preferences>Tab>Open pages in tabs instead of windows set to Automatically.

    When I changed that setting back to Never, and restarted Safari a couple of times, the problem went away. I could then switch back to Automatically and the problem reoccurred.

Topic Closed

This topic has been closed to new replies.

About this Topic