Need help? Check out our Support site, then


Preview Post - Page Not Found

  1. Hi,

    I'm having a browser-specific problem that I haven't been able to solve. I'm currently trying to use the latest version of Firefox (only recently installed), and whenever I click "preview post" on a new post I'm writing, the new tab that loads always comes up with a "page not found" error. I have confirmed that this is specific to Firefox, as there is no such problem when I attempted the same with Internet Explorer.

    In order to help resolve the issue, I have:

    a) Signed in and out;
    b) Restarted the browser and computer;
    c) Cleared my browsing history, including cookies and cache;
    d) Turned 2-step authentication off;
    e) Run Firefox with all add-ons disabled.

    However, none of these has worked, and I'm not sure what to do next. It may also be worth observing that when the "preview post" page appears with "page not found", I get the pop-up in the bottom right of the screen inviting me to follow the blog - this would seem to indicate that it believes I am not signed in, but I of course have not signed out.

    Although they may be unrelated, I have also had other browser compatibility issues, as whenever I click the orange + notification icon, the notification list never loads.

    The blog I need help with is callumjhackett.com.

  2. To those who are interested, I have since found the resolution to this problem, although I do not find it acceptable.

    After much playing around with the settings in Firefox 22, I discovered that it is necessary to enable third-party cookies in order for the "preview post" page to display properly (note that it is not enough to whitelist WordPress if you're blocking cookies in general, you have to specifically allow third-party cookies, and in Firefox you can only do so for all websites that may want to track you, or for all websites you have visited - you cannot select websites on an individual basis). For some reason, this solution also solves the problem of the orange + notification list not working.

    Obviously, I had third-party cookies disabled for reasons of privacy, and I do not find it acceptable that I should have to compromise that privacy in order to facilitate using such a rudimentary function on WordPress.

    I notice through testing that this same problem occurs in Google Chrome if I disable third-party cookies there, so it is not a problem of compatibility with Firefox. Is there any good reason why I should have to turn off this privacy feature, or can WordPress modify the function of the preview page and the notifications list in order to address this?

  3. To finish off my own post, I see that there is a support page about this, and the issue appears to relate to users who have a custom domain (I would point out that I only found the support page after I already solved the problem myself, so it would be handy if it were easier to search for this problem).

    http://en.support.wordpress.com/third-party-cookies/

  4. Hi Callum - Glad you have found a solution. I have had the exact same problem for the past few days but the third party cookies remedy has not worked for me. Others who are having similar problems can be found on the links below if your problem re-occurs. My problem continues unsolved for now....

    http://en.forums.wordpress.com/topic/page-not-found-27?replies=7#post-1355838

    http://en.forums.wordpress.com/topic/unable-to-load-the-webpage-because-the-server-sent-no-data?replies=25#post-1355805

Topic Closed

This topic has been closed to new replies.

About this Topic