Need help? Check out our Support site, then


Print friendly button only shows when viewers click on "leave a comment"

  1. I searched the forums for this answer. I figured out why my print friendly button doesn't show on my posts (I enabled them to show on posts only).

    It only shows if a viewer clicks on "leave a comment" at the end of my posts. Viewers shouldn't have to do that.

    Is there any way it can appear below my post, which is where it should be?

    The blog I need help with is cravingthis.wordpress.com.

  2. Hi there,

    If you are having trouble showing the sharing buttons on your blog, please check the following:
    I can’t see the buttons on the front page.
    Make sure to select “Front Page, Archive Pages, and Search Results” for “Show buttons on” setting. http://en.support.wordpress.com/sharing/#troubleshooting

    Unless you use the P2 theme, which is a Twitter-like theme, the front pages of our blogs showcase content and comments are collapsed on that page and you cannot change this. The way the comments function is coded into the core of WordPress. By clicking the post title or the comments link the posts on the front page open on their own page where all comments display.

    In a new blog one does not have many posts or comments. In an established blog if the comments did not collapse on the front page it would become a mile long in no time flat and page loading time is a page ranking factor. We have only seconds before visitors refuse to wait and click out.

  3. If you want the sharing buttons to show on the main page of the site as well, go back to settings > sharing and from the pulldown select to have the icons show on posts, pages and index page and then click "save."

  4. Hi timethief,

    I read those 2 links previous to asking my question, thank you for attaching though. The 1st link is how I learned to add the print button.

    I understand what you’re saying about visitor’s comments and the page loading issue. To see them, a visitor has to click on either 2 comments (the number of comments left) or the “leave a comment” to see them all.

    • What I wanted to know is why the “print” button is embedded there as well.

    I would like it to show right after this sentence for example: Source: Marie-Hélenè’s apple cake – Epicurious.com

    • Is this not possible at all in wordpress.com, or the only way is to use the P2 theme?

  5. Hi thesacredpath,

    Thanks, I figured that out as well and kept them only to show on my posts and not my "about me page."

    It's the print button that I can't figure out, it's embedded within my "leave a comment" box, but needs to be clicked on by a visitor before they can actually see the print button.

    I've asked timethief if this is specific to wordpress.com, and can only be resolved by using the P2 theme.

  6. I went back in this morning, followed the "PrintFriendly.com" instructions from their website and tried again, and the print button is exactly where I want it to be.

    I do know that yesterday, I chose the "print button" that was already in the list that WordPress provides. Today, I chose the one that I created from Print Friendly.

    WordPress print icon was imbedded with my "leave a comment" section.

    Printfriendly button was right below where my posts ended.

    Thanks again! It's all coming together (albeit slowly for me).

    Appreciate your patience timethief :)

  7. @cravingthis
    It's good to hear that the button is now where you want it. Happy blogging! :)

Topic Closed

This topic has been closed to new replies.

About this Topic