Need help? Check out our Support site, then


Private post showing up in recent posts

  1. Hi is there a way to prevent a private post title from showing up in "Recent Posts" other than removing the entire "Recent Posts" widget? I want it to be hidden away from any eyes. Though people can't access it but I'd still like the idea of not letting anyone know I'm posting a private post.

  2. Removing the Recent Posts widget is all you can do to ensure that a Private post isn't "detectable".

  3. Um, no.

    A private post shouldn't be showing up in the Recent Posts list. Was it marked Private when you wrote it? The sidebars are cached so you may be running into that if you've changed the status of the post. What I would do is remove the widget from the sidebar and click on save changes. Wait a bit and add it back in.

    Please let us know if that fixes the issue.

    Hope this helps,
    -drmike

  4. Hi drmike. Thanks. I've marked the post as Private initially before posting them up. Had done what you suggested and even clear the cache as well. Browsed my blog using different PCs and the Private post titles are still showing up in the Recent Posts widget even though I'm not logged in. I guess the solution you provided did not solve the issue. Any advice?

  5. Support should be working now, so I'd send a feedback and ask. But I tell you, people LOVE private posts; their hits are crazy, even if nobody knows the password.

  6. I don't understand why people make a post privately and want it hidden inside their blog? Not that I'm against it, it's just that, if it's considered private why blog about it?

  7. they only want a certain people to know? private posts can still be viewed by other wordpress bloggers when logged in...

  8. Not if they're password-protected, though.

  9. yea but private does not equate password protected. private is only unseen by non-wp bloggers or wp bloggers who are logged out. password protected posts are visible but security is guaranteed.

  10. Any why have a private post function if you don't use it?

    And no I do not wish my blog to have a high viewing rate.
    It is only for my friends and me, myself and I.

  11. Hi drmike,

    Is there any other way to resolve the matter?

  12. Did you send in a Feedback to staff?

  13. Hi oinky,
    This is what I found in FAQ..
    Remember: clicking “Publish ” will always publish your post publicly on your blog, even it the post status is Private. (same goes for private and draft posts)
    A 'published' post is also then available in your blog feed. If you change the post to Draft or Private you cannot stop the already posted information for people reading your feed.

    I'm trying to setup moderated blog for my friends and classmates and I would be glad to know if I could implement this idea of 'private post' to my site..

  14. No I didn't use the Publish function. I used the Private and Save function and it still shows up on my Recent Post Widget.
    I know it does not update in real time, but I've already posted it for a few days and it's still showing. I thought it wasn't supposed to show up at all in the beginning?
    Now it's still there.

  15. oinky: to my understanding, marking a post private would make it visible to wp.com bloggers logged in, but not readers who do not have a wp.com account or are logged out of wp.com at the moment.

    i believe that you're still seeing the private post in your recent post because you're logged in. maybe you can try logging out before going back to your post and seeing the recent posts at your sidebar. if it is not visible there, then your private post invisibility there is guaranteed.

    if you don't want anybody except your friends to see the post, then you must password protect it and give them the password. it will be visible but just the part where it asks for the password. no part of the content will be visible.

  16. Hi sulz. From the FAQ. "Private. Selecting this option will make a post private when you click “Save”. This means that the post will be visible on your blog, but only to you when you are logged in."

    I'm sure that no one other than myself is able to view that private post. What I want to know here is whether if I do the above, it will still show up in the "Recent Post" widget. If I want it private, I want it not to be made known to anyone. Not even showing them the title which drmike had confirmed from the top second reply.

    But it is still showing even when I'm not logged in. Just wanna know what went wrong. Hope it can be resolved soon.

  17. i just checked your blog. i don't see any posts marked private, not even at the recent posts. so you're right about that, thanks for clarifying. did you send feedback?

  18. I have the same issue on my blog. I have a private post, but it shows up in the list of recent posts, even when I'm logged out. I have also viewed my blog on another computer, where I have never logged on, and I can see it in the recent posts list there, too.

  19. It's doing it for me as well when I do a test post. Seems strange, but I do have one idea which might work. Instead of doing a private post, create a private page. You want to make sure you click save (not publish) and that you set the page to have a parent.

    If you do that, then it's not a post so it won't show up in recent posts, and the page shouldn't display in top-navigation or the pages widget, because it's private and assigned to a parent. It's a workaround, but I've tried it and it's working for me; the page is effectively invisible.

  20. And do let staff know, including the URL of the post. Email support at wordpress dot com.

    Also: is the link in Recent Posts clickable?

  21. Marking a post "Private" seems to be a bit misleading if it still shows up in "recent posts" and in your RSS feed. Do Posts or Pages marked "Private" also then show up in Search Engine results if you've marked your blog to be crawled? I would assume yes.

    So the only way to block people or a crawler from seeing a Post/Page would be by password protecting it?

    This is timely for me and I hope it gets resolved soon.

  22. I hadn't noticed before because I don't use private posts, I just tried it out on my test blog. But now I just noticed that the private post isn't visible in the recent posts widget using the Cutline theme, but it is on the Rounded theme. And the link is clickable on Rounded as well. What would that be, a fault with the theme?
    http://cjtestblog.wordpress.com/
    http://cjtestblog.wordpress.com/2007/08/22/test-post-2/

  23. That would definitely be a theme issue. How strange. Definitely needs a staff fix.

  24. Was just strolling through the FAQs and had a thought. What if you have a private page and use the Pages Widget in your blog sidebar? Will a private Page show up there?

  25. Make a test one and find out. And definitely let us know what template you use, since it seems to be template dependent.

  26. @raincoaster-I'm presently using Cutline and I'll definitely give it a try as soon as I can. (Kof-peeking in from work) Meantime, could someone answer my question whether password protecting a post blocks it being crawled by search engines. Thanks for the help.

  27. You will still show hits, but those hits will be from people coming to the password and bouncing off. It will not reflect people actually reading the post. I've tested that.

  28. I just checked and now the themes seem to be normal again; Rounded and Contempt aren't showing the private posts anymore, nor are any others I'm trying. This is getting weird... what do you think, Rain, should I email support or see if it happens again?

    @justjennifer - Making a private page shouldn't be a problem; I tried it earlier and it didn't show up in the navbar or the pages widget. Just to be sure, I set it to a page-parent as well. It's a workaround, but it seemed to work. I don't think search engines should be able to crawl it. It should be like changing your blog privacy for an individual page.

Topic Closed

This topic has been closed to new replies.

About this Topic