Need help? Check out our Support site, then


Private Posts not showing

  1. When I am logged in, I cannot view the posts on my blog that I have marked as Private. I have to mark them as Published in order to be able to see them. Up until last night, I did not have this issue. Is this a change to WordPress? Is it a bug? Can we please go back to the way it was before?

  2. You are logged in as the Admin of the blog, correct? Just wanted to make sure.

    I see from your IP address that you're on an Earthlink connection. The first thing that comes out of my mind is that you're seeing a cached page since they use proxies for almost all if not all of their connections. I would go ahead and try clearing out your local cache and forcing a reload of the page just to make sure though.

    But since you've said that this wasn't a problem in the past....

    Hmmm, I don't see it either when I do a Private tag.

    Feedback sent with a pointer to this thread.

  3. I've just posted a password-protected post to my blog. It appears to be protected in IE and Firefox.

    Send in a feedback and name the posts you are having a problem with please.

  4. Podz, the poster has an issue with the Private posts, not the Password Protected ones. :)

  5. It's late - in fact it just turned into Tuesday here :)
    The names of the posts would be good though.

  6. Podz, for me it's this one with the label of "Test post to check private flag"

  7. I just wrote one, marked it as Private, saved.
    And it disappeared.
    Definitely funky.

  8. It's late - in fact it just turned into Tuesday here :)

    I think it's time for a another new employee over in BBQ land. :)

  9. I am having the same problem. This is terrible! All my private posts have disappeared. (NB I can still access them via "Manage" but I can't read them on my homepage, they no longer appear in the flow of the blog, etc.) Please, wordpress, switch it back to the way it was.

  10. I have a similar problem. I have 2 pages marked "private".

    On the "Page Management" screen, neither the "edit" nor the "delete" actions appear next to those pages in the list.

    The "view" button appears in the list, but selecting it results in "Error 404 - not found" (however, that is normal).

    Using a direct link to the page, my dashboard displays the message "You are not allowed to edit this page".

  11. I wanted to chime in with the same problem. I created a page on June 6th and marked it Private. I was able to view it for a couple of days. Today I wanted to edit it and found that on the Page Management screen, there were no edit/delete options for this particular page. When I click View, I see a message "Sorry, no posts matched your criteria." It is one entitled "Luna-Family".

  12. I've been having this problem for a few days too. I've logged out and logged back in, but even when I'm definitely logged in, I can't see any of the posts I've marked as private. The latest private post is called "pull me back home". I've also noticed that WordPress just recently started asking me "Are you sure you want to do this?" when I try to save a private post or a draft - something which it normally never did. I don't know if that has anything to do with the problem, but there ya go.

  13. My page is back! I marked as a Draft and until I hear otherwise, Private is for the birds.

  14. Private posts no longer show in the blog chronology. They show in Manage->Posts screen and when you visit a private post's permalink page. This was changed because we received lots of feedback saying, "I marked a post as private and it stills shows up on the front page." If you preferred the old behavior, let us know. We'll go with whichever method means reading less feedback. :-)

  15. If you do decide to change the private post behavior again, please remember to check what it does to private *pages* (*not* posts). Private pages became unusable (see my previous forum post).

  16. jgiors, I politely point out that you might want to send in a Feedback with specific examples and spell it out for them.

    Being specific to show them what is going on and Feedback so that not to show us your private posts and pages. :)

  17. OK, I sent feedback.

    However, I will add that I am confident this was a *global* problem which affected *anyone* using private pages (i.e., not just me), so it isn't a "private" problem.

    Perhaps having some public posts about it will help others figure out what happened.

  18. I meant you didn't want to be pointing to your private pages here in public when you gave examples. :)

  19. OK, sorry for misunderstanding. :)

  20. No big.

  21. What? That feature is one of my favorites in WordPress! I think most people like being able to see private posts in the blog chronology, but just need to comforted by the fact that only the owners of the blog can see it, and not everyone else.

  22. I agree, goodgirl. Perhaps allow private posts/pages to show on the blog page again, but with an icon/tag indicating their private status (and therefore only visible to the authorised user)?

  23. Please read the thread you post in. I do believe Ryan mentions on what to do if you take issue with this. :)

  24. Dear Ryan,

    I find this change (that private posts no longer show on the front page when you are logged in) extremely upsetting and it is a radical breach of professionalism for WordPress. I chose WordPress over other blogging sites precisely because of the functionality of private posts. Your recent change effectively eliminates this functionality and for you to force this on users is cruel and means that you were falsely advertising WordPress functionality that you didn't intend to support or maintain.

    I understand that there could be reasons for some people to want private posts not to appear on the front page, even when they are logged in. This amounts to using the function differently. Though they were complaining about 'private posts still appearing' in fact they misunderstood the use of the existing system and really were asking for another function, namely having posts that don't appear even when logged it. Instead of merely adding that function, you added it and took away the one we use. Why not just have both? That is, each private post could have a little box that you check if you want the post to appear on the front page when logged in, and to leave unchecked if you don't want the post to appear, or vice versa. Then everyone would be happy and you wouldn't have to take sides, and you wouldn't have to receive any irate emails about this.

    Please let me know if you would consider such a modification (or otherwise restoring the function you took away), or when you are working on it, lest I start looking for other blogging options.

  25. homotopy, send feedback. That's the best method of making a suggestion around here.

  26. I want to echo what homotopy said...but don't know how to send feedback. Please advise. :)

  27. You can send Feedback via the Feedback link at the upper right corner of your Dashboard page. If you click the link, a form should open up for you to send in your thoughts.

  28. ok so this is my problem too. i just want to put a private post to not appear in the homepage, because i want to link to it from a sidebar widget instead (so it's like a special posting away from my regular posting).

    so what has finally been decided? because I can still see my private post on the homepage, but i dunno if the others can see it. tried to do a private page post as well but it still shows up on my homepage.

    any alternatives or suggestions on how i can accomplish my goal?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.