Need help? Check out our Support site, then


Problem creating contact page

  1. I feel like a total idiot, but I tried creating a contact page and it just doesn't seem to be working. I went to the WordPress Support Contact Form page and did exactly what it said to do under the "Add a new contact form" section, and ended up with a page that said "Contact" and then a comment box. No form to fill with name, e-mail, website, text.

    To break it down so you know every step I did, here it is.

    1 Clicked on Create a new page
    2 Typed "Contact" in the Subject line box
    3 Clicked on the "Add a custom Form" icon in the Upload/Insert line
    4 Left the fields alone
    5 clicked on the "Add this form to my post" button.
    6. got the short code [contact-form] [contact-field label="Name" type="name" required="true" /] [contact-field label="Email" type="email" required="true" /] [contact-field label="Website" type="url" /] [contact-field label="Comment" type="textarea" required="true" /] [/contact-form]
    7 Hit "Publish" in the publish box

    My result: A contact page that has "Contact" skipped space, then "Comment" with a box below for comments.

    So what am I missing? What stupid mistake am I making? I have noticed that when i go to edit the page, that the short code ends up missing. Is that the problem?

    The blog I need help with is thoughtsramblingsanddaydreams.com.

  2. aaroncohenphotography
    Member

    So you're saying you made a feedback box in a post?
    That's what I do. To see mine, go to http://aaroncohenphotography.wordpress.com/contact/

    You add a feedback box, and you can let people type in whatever you make it. So for me, it's their name, email (optional), a contact message, and how they came across my website. That will it'll get sent straight to your email, but from wordpress, so they don't know your email.

  3. @gene3067: If the code is missing, then that's your problem. (But yes, I know, we haven't found the source yet). Could you try some of the tips here?
    http://en.support.wordpress.com/browser-issues/

  4. Log out of WordPress.com and then look at the page. I think it's not showing those options for you because it knows you're the admin of the blog.

  5. Thanks for the quick response guys.

    I refreshed logged out and refreshed the page sand still end up with the same problem.

    I will totally erase all my browser history to see if it changes anything.

    aacohen99 what you have is exactly what I am trying to make.

  6. Well I just deleted all history three times. (two via internet options and tools and one via Norton)

    Still the page is blank

    http://thoughtsramblingsanddaydreams.com/contact-3/

  7. To explain the contact-3 part. I tried this two times before and deleted the pages when they didn't seem to work.

  8. aaroncohenphotography
    Member

    So create a new page, title it "Contact Me" or whatever you'd like.
    Under the title, where it says "Upload/Insert" click the third icon, it looks kind of like a ruler.
    Now a pop-up window should appear, where you can customize your contact form. Is THIS working for you so far, or are you not even able to do that with your problem yet?

  9. All that worked every time I created and recreated the page.

    Then I get the short link after clicking the "Add this form to my post" button.

  10. I have to go to sleep so I can get up for work tomorrow.

    Thank you everyone for your thoughts and ideas.

    I will check tomorrow to see if any onther hints and helps come my way.

    Thank you again.

  11. Some questions:

    What browser are you using?
    Are you creating the form from the Visual Editor or HTML Editor tab?
    Did you save the Page at least once before creating the contact form?

  12. Create the contact form code from the HTML tab in the editor and see if that doesn't do the trick.

    Also, while on that page in the editor, click on "screen options" at upper right, activate "discussion" and then scroll down below the editor text area and disable comments and trackbacks on that page in the "discussion" module.

  13. I'm using intrernet outlook/windows for my browser.

    I was using the visual editor.

    Maybe I needed to save the page first.

    I will try to create the foorm in the HTML tab when I get home from work.

    Strupid question: Is the contact form available to everyone or just those who buy the $99.00 upgrade?

    Thanks again guys for all the help. You Rock!

  14. its available to anyone,
    i think its great but realtively simple functionality

    i have been tinkering with it myself recently.

    one issue i had (which may contribute to your prob) was that going back to edit it using the button erased stuff and individual buttons too were easily accidentally erased when createing the form.

    and yes you will need to save it.

  15. @gene3067: The main usefulness of Internet Explorer is that you can use it to download a decent browser, namely Firefox or Safari. Then you trash Explorer.

  16. hmm yet i see that safari still hasn't got "paste and go" functionality (like opera for ex)and can't ALWAYS properly take local files as a home page and it even crashed on me for the first time this week...just three bugs i've found and it ALSO used to be very slow (although now actually very much better in latest versions)

    IE9/latest is pretty good c'mon!! with the advantage that you just sometimes HAVE to use it to make some sites work - which is a fault of the sites not microsoft.

    i have to say that i use safari for wordpress.com blogging as it seems to work faster.

  17. I said "decent", not "perfect"! But Explorer (even IE9) continues to ignore various web standards. I've been a regular in these forums for three and a half years: when complaints prove to be browser-related, it's almost always IE, sometines Chrome, almost never Firefox or Safari.

  18. It's working! Yea! Thanks guys!

    Copying the code and resubmitting it in the HTML code is what did it.

    Thanks again to everyone here for your help.

    You all ROCK!

  19. That's good to know; it's something staff were supposed to have fixed last year! Glad you got it working.

Topic Closed

This topic has been closed to new replies.

About this Topic