Need help? Check out our Support site, then


Problem in Coraline theme with almost all browsers

  1. I am using this 3 column theme almost 1 - 1&1/2 years.
    Its working only with Firefox 3.6 and if i can remember well with IE7.
    Not any other one version nor other browsers.
    It mixes half the left column with whole right one
    and puts them in and upon the center one.
    Even after cleaning cache and reloading.
    Please find me some solution, before i am forced to move over.
    I am tired to return back to older slower browser versions,
    everytime after upgrading.

    The blog I need help with is tzapits.wordpress.com.

  2. Thanks for not answering my problem.
    Sign over.

  3. Problem looks fixed to me.

  4. I don't understand what do you mean or what you can see.
    Right know i'm in my blog, with either FireFox 11.0, with Internet Explorer 9.0.8112 and with Chrome 17.0.963.83 m.
    I can't see 3 columns (left-center-right).
    My right column mooved in and upon the center one, both with Half my left column, all mixed over the footer, which seems to be ok.
    Where is the solution?

  5. Your blog certainly looks wrong. However I have just tried the Coraline three-column layout on my blog and that's OK. Are you using custom .css, or do you have any inline .css in your posts?

  6. Only when i'm downgrading to FireFox3.6-3.6.8, I can see then,
    what i have had since 2010, that means 3 columns.
    But it loads very-very slowly.

  7. It's possible you have an HTML error. Under Settings->General, have you selected "Wordpress should correct invalidly nested XHTML?"

  8. Only custom .css.

  9. Do you use custom .css? If you do then I would think this is an issue for the .css forum. If you don't then I would suggest submitting a support request.

  10. Yes, I did. I' ll change it, re-sign in and see.

  11. Under Settings->General, have you selected "Wordpress should correct invalidly nested XHTML?" If not, select that now and Save the change.

  12. Thanks, raincoaster, but didn't work

  13. Not with cheched, nor with uncheched.
    Now i did click back to check nested XHTML.
    Thanks for the try.

  14. Since Coraline three column seems to work OK with a vanilla blog but has some problem with your custom .css I suggest you ask in the CSS Customisation forum.

  15. @tandava:
    Despite tzapits's reply above, they don't have the Custom Design upgrade.

    @ tzapits.
    The option raincoaster suggested doesn't do anything by itself: it auto-corrects unpaired HTML tags in posts if you edit the posts after you enable the option; and it cannot correct text widgets. But I checked the sourcecode of your page, and you don't have such issues.

    The world clock you've got in one of your sticky posts is wider than than the main column of the theme. You should remove that post and put the clock in a no-sidebar static page.
    In your sidebar you're displaying lots of images hosted elsewhere, and some of the originals are a lot wider than the width of the sidebar column; example:
    http://www.kodipheet.gr/images/spectrum2.jpg
    Explorer doesn't understand the 'regular' code for downsized display. A temporary fix might be to change the coding of all such images from this:
    <img alt="DESCRIPTION HERE" src="IMAGE URL HERE" class="alignnone" width="100" height="30" />
    to this:
    <img alt="DESCRIPTION HERE" src="IMAGE URL HERE" class="alignnone" style="width:100px;" />

    But the real fix is different. You're displaying an impossibly large number of items on your sidebars, so your blog pages take too long to load (and that's a page ranking factor as well). The more the items linked to from other sources, the worse. So, two suggestions:
    1. Ideally you should copy all the sidebar images to your computer, scale them down in an image editing application to the right pixel width, upload these copies via Media > Add New, copy the file URLs that will show up, use those URLs in the widgets.
    For maximum pixel width see here:
    http://wpbtips.wordpress.com/2010/08/10/coraline-layouts-and-mullenweg-pearson-dispute/
    2. Cut down on widgets: transfer some of the stuff to static pages.

  16. Thanks for the advice. I'll try to fix some.
    The world clock is only about 1-2 months post,
    but the problem is about 1&1/2 years old
    and noone ever concerned about.
    It has to do something with the theme or the css,
    it is old enough and maybe dosn't cooperrate with newer browser versions,
    or has some restrictions i' m not permitted to restyle.
    They propably don't want to fix it all these years,
    never mind. Perhaps, they need some money to do so,
    but I ' m not going to upgrade, cause not like foolish restrictions.
    There are many other hosts without restrictions nowadays.

  17. Nobody said you should upgrade, and no it doesn't have to do with the theme: as I explained, the problem is caused by the large images that aren't stored in your own blog; it can happen with any theme in bad browsers or browser versions. To avoid such issues, just make sure all the image files you use for the sidebars have the right pixel width and are uploaded to your blog (as suggested in 1 above).

    If you need more help, you can also post in the Greek forum instead of here:
    http://el.forums.wordpress.com/

Topic Closed

This topic has been closed to new replies.

About this Topic