Need help? Check out our Support site, then


Problem Inserting TXT Records (Custom DNS Records)

  1. Hi,

    I use custom domain with my blog hosted in wordpress.com (vajrasky.net). My email stopped working. After searching around, it is said that I have to insert MX, CNAME, TXT records in custom dns records page.

    I have successfully inserted MX and CNAME records. In email setting page, I got valid for those records. But I got problem with TXT records.

    Here is the instructions:

    Add the following records to the DNS settings of vajrasky.net
    .........
    vajrasky.net IN TXT "v=spf1 exists:%{i}._spf.mailhostbox.com redirect=_spf.mailhostbox.com"

    20100812._domainkey.vajrasky.net IN TXT "v=DKIM1;g=*;k=rsa;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCfu5bfpGVBO3dd8Aows4I2H3LOzFuVrFoCFpsy xQcOEl46TyqSXoWj0Kc0pM9RIg0fRuXgSs5OuoUpJJMyil/EJa1ILYnekQAUZIz5gQMU5cSzXjh2 /H0+bnrCKBtvY57toNIL+lX8vsJvHTjNbT8l8rikXjkVF2Axw1NI7pGhcwIDAQAB"

    So how do I insert these TXT records since wordpress has custom format?

    This is the email setting page looks like. Only TXT records left!
    http://i.imgur.com/qWL9A.png

    Thank you.

    The blog I need help with is vajrasky.net.

  2. Hi. This is the correct format to follow for TXT records:
    http://en.support.wordpress.com/domain-mapping/custom-dns/#adding-custom-dns-records

  3. Hi airodyssey,

    Thank you for your reply. I managed to make TXT records (record type SPF) valid. But I have difficulty with TXT records (record type DKIM).

    As you can see in my image link (http://i.imgur.com/qWL9A.png), the txt records (record type DKIM) is very long. When I put it in form, WordPress gives me validation: "1. TXT data must be 192 characters or shorter."

    Any idea?

  4. In that case, I'm out of ideas, sorry. You'll have to contact staff at support@wordpress.com

Topic Closed

This topic has been closed to new replies.

About this Topic