Need help? Check out our Support site, then


Problem loading images from other websites

  1. I am having problems loading images on our blog, http://blog.golfthere.com (hosted by wordpress.com, but custom URL). I am trying to load an image from PicApp. I went in to my post, selected insert an image then selected from URL. I posted the code from PicApp specifically for WordPress.com (also tried the generic), but it keeps showing a RED X in the url spot like it is a bad URL. Any suggestions on how to fix this or am I doing something wrong.

    The blog I need help with is blog.golfthere.com.

  2. I use a Firefox 3.6.4 browser and if you are referring to the image in this post > Limestone Springs Golf Club I can see it and no red X.

    1. Which browser and version of it are you using please?
    2. Have you logged out and force cleared your browser cache and cookies? If not please do so > http://en.support.wordpress.com/browser-issues/
    3. Have you tried an alternate browser? If not will you try one now?

    Also note that you can go to this free site and see how you blog displays in various browsers http://browsershots.org

  3. Sorry, I wasn't clear on this. No, I am confident the images I have loaded are displaying. Those have been loaded from my PC.

    I am trying for the first time to load an image using PicApp. When I go in to WP and select add image and then select 'From URL', I put the URL in where I should and I get a red x in that box next to the link, like WP.com sees it as a bad link, but I took the link directly from PicApp for WordPress.com. Is there something that I need to enable to make this work?

    Thanks,

    DK

  4. One more thing...I have tried this from both Firefox and from IE with no luck

  5. Hmmm ... it sounds like you need Staff help so here's the contact link. http://en.support.wordpress.com/contact/

  6. Thank you Timethief...as always you have been very helpful, also the browsershots.org website is VERY cool and helpful for other things.

    I will contact staff and see if they can resolve.

  7. I'm glad I was able to help you in a small way. I'm sure Staff will be able to sort your problem. Best wishes for happy blogging. :)

  8. @golfthere: Please paste here the URL you're trying to use.

  9. Picapp has occasionally had some technical issues of its own; they're normally quite reliable, but the problem COULD be on their end.

  10. golfthere --

    I have been setting up some blogs here on WordPress.com over the last few days and I had the same trouble you are having with getting remote images to "green check" by loading from a URL.

    The images I wanted to load are from my own private server -- so I knew the images were alive and working elsewhere -- and while I have .htaccess hotlink protection, the WordPress.com blog URLs were included as approved remote images pullers.

    Here's where it gets strange: While the images would "Red X" under Firefox for Mac, they would load just fine in the WordPress.com editor using Safari for Mac and Google Chrome for Mac.

    Very strange.

    So, I did a lot of testing, and it came down to me having to turn OFF "Always use HTTPS when visiting administration pages" in "Browser Connection" in "Personal Settings" here on WordPress.com.

    After I removed the HTTPS connection, and cleared my cache and closed Firefox -- I was able to get the "Green Check" loading remote images via URL under Firefox.

    If you aren't using HTTPS -- then I'm not sure how to help you, because I tried everything else... turning off Flashblocker and Adblock Plus and a whole host of other features in Firefox and WordPress.com and on my private server... and it was WordPress.com HTTPS that was causing Firefox to choke.

    Best Wishes,

    db

  11. Hi there,
    Using Picapp images should be done via the embed code. There is no uploading of images through URLs. See here: http://picapp.com/PisEmbedGuide.aspx

    Please let us know if you run into problems: [email redacted]

    Best,
    The Picapp team

  12. Thank you everybody, but I am still having the issue. I have selected more than a dozen pictures from Picapp, but have been unable to get any of them to load. I will try what Boles mentions and see if the HTTPS settings is the issue.

    A really big thank you to all of you that post on here. You always make my life easier.

  13. Which specific images are you trying to use? Paste the code you're trying to use in here so we can look at it. Put it between backticks, those little marks usually on the same key as the ~, so the code shows up properly.

  14. I don't know what boles and couchpanda are talking about: I use Firefox, the "Always use HTTPS" option is on, and I just inserted an image from PicApp via its URL. So, as I said before, and as raincoaster is saying, will you please paste here one of the URLs you're trying to use?

  15. We need the whole thing from the "Wordpress.com" box that you're trying to use.

  16. I have Firefox for Mac locked down and my servers are locked down -- and the fact that the remote image URLs load in Safari Mac and Google Chrome Mac on the same machine -- suggests there's something wrong with the way Firefox is interpreting secure connections. My workaround was to just disable HTTPS on WordPress.com while using Firefox. I'm usually in a VPN tunnel, so the extra layer of security provided by WP.com isn't really necessary for me.

Topic Closed

This topic has been closed to new replies.

About this Topic