Need help? Check out our Support site, then


Problem with comments

  1. smallwalletbigappetite
    Member

    On Friday a reader emailed me to say they were having a problem leaving a comment on my blog. I hadn't changed any settings so I didn't know why there should be an issue. To allow them to comment in that moment I turned off the need to be logged in. This seemed to fix the problem but I have been told that many people are still having this issue. And to make matters worse it seems that most of my postings have the ability to leave a comment turned off even though my settings are set on. What is happening and how do I fix it?

    The blog I need help with is www.smallwalletbigappetite.com.

  2. Hi there,
    The prompt still appears and even though it can be ignored your visitors aren't catching on to that.

    To confirm your settings go to > Settings > Discussion is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    Discussion Settings
    Other comment settings
    _Comment author must fill out name and e-mail
    _Users must be registered and logged in to comment

    The prompt to submit and email address and a website URL will still appear but providing an email address and logging in are not required. If you wish you can place a notice in a text widget so your visitors understand that. http://en.support.wordpress.com/widgets/text-widget/

    Also note that spammers deliberately seek out blogs that have anonymous commenting set up. Over 80% of all so-called comments submitted to WordPress.com blogs every day are spam. Your spam will increase dramatically so I suggest you set comment moderation up. http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

  3. And to make matters worse it seems that most of my postings have the ability to leave a comment turned off even though my settings are set on.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    See also: Don’t discard spam on old posts http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

  4. smallwalletbigappetite
    Member

    Right now I went into Settings > Discussion I have these selected:
    Attempt to notify any blogs linked to from the article
    Allow link notifications from other blogs (pingbacks and trackbacks) Comment author must fill out name and e-mail selected
    Anyone posts a comment

    Nothing else is selected. I have not manually over ridden any posts to not allow comments and yet all of my old posts have "Allow Comments" unchecked

  5. Oh RATS! I am really sorry. I made the classic error of assuming you were posting to the correct support forum and did not click into your blog. On the footer of this blog http://www.smallwalletbigappetite.com/ click the "powered by WordPress" link and note it's linked to http://wordpress.org/

    We cannot help you here at WordPress.com with that site as it’s not being hosted by WordPress.com and we run on different software. This is the correct forum for your software http://wordpress.ORG/support/ If you have not registered a WordPress.org username account yet you can do so on the top right hand corner of the page I just linked to so you can post to those support forums.
    WordPress.com vs WordPress.org: The Differences
    http://support.wordpress.com/com-vs-org/
    Best wishes with your site.

  6. smallwalletbigappetite
    Member

    Oh okay. Thanks

  7. smallwalletbigappetite
    Member

    Sorry I didn't mean to post the question to the wrong place. I will contact my host and see if they can help me.

  8. Not to worry. I should have checked first and I didn't.

Topic Closed

This topic has been closed to new replies.

About this Topic