Need help? Check out our Support site, then


Problem with embedding GoogleDocs form

  1. Hello - Just trying out the Google Docs embedding, and tried embedding a ridiculously simple form into a page, just to try it out. However, the form doesn't display. The form is shared publicly, and I'm using a plain theme (on the form), MistyLook by Sadish for my WordPress theme.

    I get the embed code from Google, add a new post, or page, paste the embed code in HTML view, and nothing shows up on preview, or publish. What am I missing?

    The blog I need help with is cvanhasselt.wordpress.com.

  2. hello,

    you could use the wordpress form - in the post screen where the buttons are for inserting media, polls etc, there is a button at the end that says insert a form.

    im no techie but seems you can and cant do certain things with certain themes, so maybe give this form button a try out instead?

  3. Many, many MANY people are reporting problems with this over the past few days. Report it to staff.

  4. @vmc1978: I want to use Google docs because it offers more flexibility than standard post forms. And, not to put too fine a point on it, it is supposed to work:
    http://en.support.wordpress.com/google-docs/ - halfway down the page, I followed the instructions for inserting a form, both in a post and a page, in both unpublished preview and published mode. I haven't been able to get this to work as advertised. At this point, I'm really just "kicking the tires" on this feature, but frankly I am surprised - I've yet to see something from WordPress.com that just works!

    @raincoaster: I was under the impression that staff read the forums? Is there a separate place to submit to staff? If so, please point me in that direction.

    Thanks to both of you for responding so promptly.

  5. Oops, that must have been my subconscious speaking. I meant "I've yet to see something from WordPress.com that DOESN'T just work" Seriously, I've always been impressed with the quality of the WordPress.com platform, and I am genuinely surprised.

  6. No, staff generally don't read the forums. There's a special forum to contact staff, but the best way is via your dashboard Help button.

  7. @cvanhasselt
    Others have been experiencing the same issue. Click this tag and see what you find. http://en.forums.wordpress.com/tags/google-docs

  8. Thanks for all of your help, after following @timethief link and carefully reading it all, there was one plain English explanation of what to do. II found one post with complete sentences with verbs, nouns, prepositions, etc. :-) That helped a lot, and the solution was ... envelope please....

    change the
    dir="spreadsheets/embeddedform" parameter
    to
    dir="embeddedform"
    (applause!)

    I know this is an interoperability bug, and with WordPress and Google being pretty aggressive about updates, I'm sure it was somehow overlooked in testing. I understand this is probably a feature that few people use, so I'm happy with a good workaround. Thanks one and all!

  9. @cvanhasselt
    Hi there. Thanks for letting us know this. I flagged the thread to bring it to Staff attention. :)

Topic Closed

This topic has been closed to new replies.

About this Topic