Need help? Check out our Support site, then


Problem with gallery columns

  1. On my blog http://www.archuletafansgermany.com I often use the gallery tool to create articles with pictures from events and whatnot. It always worked supberbly, but as of yesterday, for whatever reasons, all the galleries I newly create are displayed as single columns even if I choose 2 or 3 columns. I tried changing the html-codes manually, and even though it does save the change, the galleries are still displayed wrongly. Now, for some posts I want single columns, but not ALL. LOL

    Galleries I created some time ago are still being displayed correctly, btw.

    Please, can anyone tell me what to do? I've been trying to figure it out on my own for two days now, and can't find any solution.

  2. It's a bug that hasn't been corrected: if you've got more than one gallery posts in the same blog page, the newer ones will adopt the number of images per row of the older one, no matter how you set them to be.

    For the best info on galleries see here:
    http://gammagirl.wordpress.com/2008/07/27/not-the-official-wordpresscom-gallery-faq/

  3. hey pana, thanks for the referral. I hope to get that darn FAQ updated soon.

    The Gallery column bug is supposed to be addressed in 2.8, along with what looks to be an overhaul of media handling (again!). http://trac.wordpress.org/ticket/7678

    Having said that,

    @anys77- you can't edit the html of Galleries manually, unless you mean manipulating the shortcode.

    -can you post a link to specific posts where you are having the problem so we can see if we're talking about the same thing.

  4. My picture gallery columns change from three columns to two columns and back again even though every gallery is set to three columns.

    Not sure of the reason it keeps switching, whether it is because of new postings or bugs in the code but it is annoying on larger galleries that are too long when they revert to the two column layout.

    Clicking on the single post perma-link shows the three column gallery while the front page shows two.

    Can't tweak the code because it is a free hosted on wordpress.

  5. We can't help you without a link to your blog, starting with http.

  6. Whoops, I thought my avatar linked to it:

    http://coosoregonnews.wordpress.com/

  7. Did you read my reply above?

  8. Got it, panaghiotisadam. Thank you. I did not fully understand your point though you said it well.

    While doing anything related to the internet I have accustomed myself to skim reading, which I need to stop doing.

    Then I will only include galleries of at least three pictures.

  9. Or you can set your front page to display one post only (Settings > Reading). But note that this will also apply to category pages.

  10. panaghiotisadam, so according to my blog page:

    http://coosoregonnews.wordpress.com/page/2/

    all gallery posts will adopt the number of picture columns of the OLDEST post on that page, correct?

    Which is why I still have a three column gallery, because the oldest is a three column?

    What a delightful bug!

  11. Correct. (And not at all delightful!)

  12. And again, according to the last info on that bug ticket http://trac.wordpress.org/ticket/7678 , media is scheduled to be overhauled in 2.8

    Can hardly wait.

  13. Same issue for me. I am really looking forward to the fix. http://marineharvestcanada.wordpress.com/

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic