Need help? Check out our Support site, then


Problem with HTTP and HTTPS

  1. Hi,

    I am building a website for a customer and they need it to be straight forward and update-able in the easy form of a free blog site. I have chosen WordPress as the host.

    I am having loading and access issues where the link hooks to http and not https. How do I set ALL internal page links and the http://www.beldabridal.co.uk access URL to be in https format?

    TRY: http://www.beldabridal.co.uk (how slow was it for you?)
    THEN TRY: https://www.beldabridal.co.uk (faster? What about the certificate error? I need that to be removed too)

    Just so that you know, I am using wordpress.com for free 'hosted' web space for a side project. I am not using wordpress.org, which is the one where I'd have to download WordPress software and do all the hosting myself. I am trying to fix the issue on all IE platforms, be that Internet Explorer, Chrome, Firefox, etc. I am also trying this on several PCs and laptops, and I do clear the cache, cookies and internet history all the time too. Also, there is no need for actual security on the site. There is no e-commerce etc. Just a plain blog with pages and pictures.

    In more detail:
    What happens is, if I type the website address as:

    1: http://nameofurl.co.uk/
    The site hangs and does not load for ages. When it does, all you get is the plain text and no formatting to the style of the web page. Everything is pushed to the left of the screen and the theme style sheet does not load. Sometimes, I get timeout errors.

    2: nameofurl.co.uk
    Same as above.

    3: https:nameofurl.co.uk
    the site loads straight away and looks perfectly how it should. This is what I need. But I cant find out how to force WordPress.com to ensure that all access to my site is via automatic httpS and to ignore or overweite http with httpS. BUT I also need to resolve the trusted site certificate warning issue. Is there a way of stopping this from happening for general customers anywhere in the UK accessing the site?

    NEXT, if I click an internal link to a particular page in the site/blog, the same thing happens as per the http attempts and I have to intervene on the browsers address bar by popping the 's' in to make https before it will load.

    Finally, I need all pages, and the original landing access to the site to always be in https format.

    Any help would be fantastic, as I am ripping my grey hair out!

    Many thanks,
    Jon.

    The blog I need help with is beldabridal.co.uk.

  2. TYPE-O ABOVE!!

    Where I have put the steps 1 to 3, I forgot to type the // marks in the varied URLs I am demonstrating, so here they are again, for clarity...

    1: http://beldabridal.co.uk
    No good, slow, loads no theme. Timeout errors.

    2: http://www.beldabridal.co.uk or beldabridal.co.uk
    Same as above.

    3: https://beldabridal.co.uk
    Lods first time, fast and perfect.

    Thanks,
    Jon.

  3. Hello there,
    Please read this https:// section on How do I get those annoying security warnings to go away? of the support documentation for free hosted WordPress.com blogs.

    Also, please note that WordPress.com automatically removes the “www” from all URLs. Any traffic to http://www.example.com will be redirected to example.com. http://en.support.wordpress.com/domain-mapping/map-existing-domain/#before-upgrading-important-notes

  4. I am using Firefox 6.0.s
    The first two links you posted here load almost instantly for me. There is no difference between them when it comes to page loading time. > http://en.forums.wordpress.com/topic/problem-with-http-and-https-1?replies=3#post-707049

    The https:// URL is only for Admin pages and produces an error message
    "This Connection is Untrusted"

  5. I'm sorry. I am using Firefox 6.0.2

  6. houseislikelava
    Member

    I have slightly the same problem, but I get this;

    thefashionists.com uses an invalid security certificate.

    The certificate is only valid for the following names:
    *. wordpress.com, wordpress.com

    (Error code: ssl_error_bad_cert_domain)

  7. Please read this https:// section on How do I get those annoying security warnings to go away? of the support documentation for free hosted WordPress.com blogs.

  8. houseislikelava
    Member

    I get it, thanks a bunch for answering, but I do get it after I have logged out..

  9. Hello again,
    When you make adjustments to your browser settings — you will need to close your window and restart the browser before those new settings become effective.

    Which browser and version of it are you using? Have your tried clearing your browser cache and cookies? http://en.support.wordpress.com/browser-issues/#clear-your-cache-and-cookies

    Is your browser version up to date? You can upgrade any browser version here.
    http://browsehappy.com/

    Do you have third party cookies enabled?

  10. houseislikelava
    Member

    I am mainly using chrome the latest I think, but I use a server network there I work, since I am doing my blog at work. I will do this when I am at work on monday, thanks for the helo!

  11. You're welcome and best wishes with your blog. :)

Topic Closed

This topic has been closed to new replies.

About this Topic