Need help? Check out our Support site, then


Problem with pages

  1. At the time of writing, I have a page, created under a parent page, sitting in "All pages" but not appearing in the list of pages in the widget column (on the right) when I view my site. Any idea why this is happening? I also wonder what "Order" means in the page-creation area. Is this supposed to control the order in which the pages appear? Thinking it might do that, I numbered my pages - only to find that they did not come out in the order I wanted. I have been using WordPress for some time - for about two years, I think - and have never had any difficulty with it, except when creating pages and trying to get them into the desired order. For some reason, this seems to be problematical.

    The blog I need help with is hourglassera.wordpress.com.

  2. The Pages widget normally displays all your published static pages, and child pages show up (indented) under their parent. Is the page in question private perhaps?

    To set the order in the Pages widget, you enter order numbers in the Page Attributes module of the page editor, then open the Pages widget, select Sort by" page order, Save.
    Alternative: create a custom menu and use a Custom Menu widget. Details here:
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/

  3. Thank you for your speedy reply. No, the page in question was not marked private.

    I've made some progress. All the pages are now showing, and after some fiddling around - adding the pages twice, and then deleting half of them - I've got them in the right order. (Entering order numbers in the Page Attributes module of the page editor doesn't seem to work, so I'm clearly still doing something wrong.)

    "Family register notes", although under its parent, is not indented, despite the fact it's indented on the Menus page. But I can live with that. I just hope that, as I add more pages, I can get them in the desired order.

    Don't really understand a lot of that stuff at http://wpbtips.wordpress.com/2011/12/19/custom-menus/ Might have another look at it tomorrow.

    Thanks again. If you have any further suggestions, I'll try to follow them.

  4. "then open the Pages widget, select Sort by" page order, Save."

    Where is this widget? There's a widget marked "Pages" on the widgets page, but I can't see how it can be opened. Am I looking in the wrong place?

  5. Dashboard > Appearance > Widgets >
    Pages Widget - click the widget and it will open
    http://en.support.wordpress.com/widgets/pages-widget/

  6. Well, it doesn't open for me. Not with a single click, not with a double click.

  7. It doesn't open because you're talking about the widget in the Available widgets section: you haven't added the Pages widget to your Sidebar, you've added a Custom Menu widget. Open the Custom Menu widget, delete it, drag the Pages widget in its place.

  8. Thank you. That was very helpful. I think I had been trying to get a list of pages that didn't have the word "Pages" above it. Probably a silly thing to do.

    I wonder whether you could advise me on one more matter. As you may have noticed, I am creating a conventional website, rather than a blog, at hourglassera.com. Thus, everything that comes up, at present, is a single (sticky) post. Is it possible to create another long post, reachable via an "Older posts" (or similar) link at the foot of what I have so far completed?

    To put my question in a slightly different way: If I were to keep adding to my sticky post, would it go on forever and never get broken?

  9. a) Do you mean you want a different heading above the list of pages or no heading at all? (Both possible.)

    c) In theory you can keep adding. But the longer a post (that is, the more the scrolling), the less user-friendly. Plus the more the images on a single webpage, the slower it will load: above a certain number, the browser may even time out before loading all the images if a visitor has a slow connection.

    b) Yes you can create another post in Posts > Add New. If you go to Settings > Reading and set the number of posts per page to 1, the front page will display the latest regular post only, and a link to older posts will automatically show up (the wording varies from theme to theme: in the theme your using it's "Older Entries").
    But sticky posts override the number of posts per page. So you'd need to unsticky the post you've already published, and set an earlier date for the other one.

    Alternative 1: keep the post as a sticky, don't bother with the setting for the number of posts per page, and use the more tag to truncate both posts (so that a visitor will see the beginnings of both without having to scroll down).
    http://en.support.wordpress.com/splitting-content/more-tag/

    Alternative 2: Turn your published post into a static page, then go to Settings > Reading and set your front to display that page. To turn the post into a static page, you'll need to copypaste all the content from the HTML post editor to the HTML page editor.

  10. Thank you again. I've now got everything exactly as I want it. I'll acknowledge your help on my "About" page. It's people with patience, like you, who make working on the internet a pleasant experience - especially for those of us in the 70+ age bracket, whose "technology", for most of our lives, consisted of a pencil and a piece of paper.

  11. You're very welcome, and you don't have to acknowledge my help on your page!

  12. Sorry, there's just one more thing: When my first post was sticky, my h2 headlines were given a gray background, which I rather liked. That has now gone. Is there any way in which I can get it back?

  13. No problem - that's what this forum is for!

    The grey bg is the default styling of the theme for sticky post headings only. To simulate it, you need to turn the h2 tags to this:
    <h2 style="background-color:#ccc;padding:10px;">HEADING</h2>
    By the way, this allows you to decrease the padding, if you wish, or set a different bg color. Palettes and color codes here:
    http://www.december.com/html/spec/color.html

    But you can't change the actual post title if you don't have the Custom Design upgrade. Workaround:
    1) add the title at the beginning of the content of the post, and enclose it in the above code;
    2) delete the real post title and put this in its place (minus the spaces):
    & n b s p ;

    But this will leave the "leave a comment" link at the top. Not nice, except if you don't want comments on your main post, in which case you can disable comments and pings and the link will go away.

    Couple of other suggestions:

    a) I would add some space between the images (I mean the plain ones, not the captioned ones) and the text. If you agree, you can change the image code of the left-aligned images from this:
    <img class=ETC ETC
    to this
    <img style="margin-right:14px;" class=ETC ETC
    Same thing for the right-aligned images, with margin-left in the code.

    b) Some of your headings wrap around the images. If you don't like that, paste this before the opening h2 tags:
    <br style="clear:both;" />

  14. I've bought the Custom Design upgrade. May as well do the job properly. Perhaps you would be kind enough to advise me on what to do next. Thanks, by the way, for the other suggestions. The space between the left-aligned pics and the text certainly makes the page look better.

  15. To add that styling to all your h2 headings, paste this in the CSS editor:

    h2 {
    background-color:#ccc;padding:10px;
    }

    Then you can of course remove the corresponding coding from the HTML post editor.

  16. That was easy!

    When indenting a line at the start of a new paragraph of text, I've always used the & n b s p ; code, repeated four times. I feel sure there must be something better (?)

  17. No, that's not the right thing to do. Do you want all your first line indented or only some of them?

    By the way, I just noticed your "word word" trick: that's not right either, because those words are part of the content, whether you see it or not. To place your headings below right or left aligned images, you need the clear:both bit of code I suggested in a previous reply (it stops the wrap-around effect of the images).

  18. I was thinking of the indentation one finds in book texts, in which only the first line of a new paragraph is indented. Something else I have just tried is <span class="firstletter">T</span>, to get a dropped capital letter at the start of a text. It doesn't work in WordPress.

    I have eliminated the "word word" trick. Sorry about that. Just another of the bad habits I brought with me from my previous site, where I used all manner of abominations. I suspect that's partly why Google downgraded me from PR4 to PR3.

  19. ISSUE with Internet Explorer Version 9 ? Menu squishing down the side.

    Our blog http://www.safetybox.com/worpress - renders fine in Chrome, Firefox on WIndows 7, Safari, iPhones and iPads

    But look at it in IE and the top menu buttons are down the side and barely visable, this is a customised theme ?

    Any ideas will be greatly appreciated

  20. @hourglassera:
    a) Yes, I know what you were thinking of. My question was whether you want that for all paragraphs of all your posts and pages, or for specific paragraphs or posts or pages. In the first case you'll need to add code in the CSS editor, in the second case you'll need code in the HTML editor. You must also clarify if you want indentation plus blank line between paragraphs, or (in true book fashion) indentation instead of blank line.
    b) A drop cap is also possible. Class="firstletter" can't have any effect unless you add code in the CSS editor to specify what that class should look like. And again you need to clarify if you want drop caps for all paragraphs of all your posts and pages or not.
    c) Please don't ask all your questions here: for each different issue start a new thread, with a pertinent title, so it can be of use to others as well. Also note that experienced volunteers who could help with CSS are no longer willing to do so, so for CSS questions you'll have to wait for a staff reply (users who have the CD upgrade are entitled to staff support).

    @woshearyan:
    You're in the wrong forum.

Topic Closed

This topic has been closed to new replies.

About this Topic