Need help? Check out our Support site, then


Problems with sidebar and footer widgets in new Duster theme

  1. Help! All was looking great at The Ethical Nag since switching to the new Duster theme - until today, when suddenly a number of widgets that were previously in the right sidebar are now located in the footer area, looking very weird, stretched wide across the entire page instead of the nice neat column they were in until today. On the widget page, they are showing as still being in the sidebar.

    Thanks,
    Carolyn

    The blog I need help with is ethicalnag.org.

  2. quiltguildeffingham
    Member

    I am having the same problem with the Elegant Grunge theme. noticed it last night when i went to update one of my blogs : http://crossroadquilters.wordpress.com/
    And i still haven't been able to find a "cure" for the problem! I also checked to make sure the sidebar widgets were still listed as being on the side and they are. Something must be up with WordPress?

  3. lizzyjo it looks like all of your widgets are now down on the footer. In my case - http://www.ethicalnag.org - I have half of the widgets still up on the right sidebar where they're supposed to be, but half now inexplicably down on the footer looking horrible.

    Yikes..... :-(

  4. @Carolyn
    We cannot help without a complete and clickable link to the blog in question. Will you please post it now?

    1. The Duster theme does not have a sidebar on single posts and pages.

    2. When sidebars or footers become messed up it's usually due to copying and pasting text from elsewhere without using either icon 5 or icon 6 in Row 2 of the visual editor. Please see here so you know how to do this correctly in the future. http://en.support.wordpress.com/visual-editor/#pasting-text

    It can also be a result of importing text containing invalid HTML.

    Regardless of which of the two caused it the problem will be invalidly nested XHTML which is most likely due to an open HTML tag in one of your posts.

    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    Now, starting with your latest post, open it in the editor, make one minor change such as adding a space and then deleting it, and then click “Update Post.” Check your blog and see if it is back to normal.

    If it’s not, then look for an open HTML tag and close it. Check your blog again and see if it is back to normal. If it’s still “messed up” then open the next post and do the same thing post by post until it goes back to normal.

  5. @lizzyjo
    Thanks for posting the URL for the blog inquestion. What I said here also applies to your blog so please go through those steps to fix it. http://en.forums.wordpress.com/topic/problems-with-sidebar-and-footer-widgets-in-new-duster-theme?replies=4#post-565814

  6. My blog is http://www.ethicalnag.org

    This morning, it's even worse! Now the colorful background (which originally was just in the BACKGROUND, with the post content in white) floats ALL OVER the entire page, making the content text unreadable. I quickly cleared the entire background so text is now legible. This just happened overnight.

    Re some of my sidebar widgets migrating down to the footer - I have now removed the guilty widgets entirely (calendar, blogroll, one text box)

    These were widgets, not posts. The text box contained no links, just text. It's deleted now.

    The calendar is just your standard widget calendar.

    The blogroll - could this be the culprit? It is of course ALL LINKS.

    I'm beginning to HATE the new Duster theme. Maybe it's just new kid jitters?!?! Never had these or any issues with 2010.

    THANK YOU!!!

  7. @czthomas: Nothing to do with the theme, and nothing to do with automated widgets such as the Calendar or the Links. Misplaced elements on your front page are due to unclosed or stray HTML tags in a post or a text widget affecting the rest of the page. Lizzyjo hasn't corrected the problem yet, so go to her blog ( http://crossroadquilters.wordpress.com/ ) to see: the widgets have dropped to the bottom, but if you click the title of the latest post the widgets spring back to place because the problem is in her previous post.

    Since only some of your widgets had dropped to the bottom, the problem was in your text widget. If you put it back I can examine it and tell you what it is. Or you can paste its content here between backticks.

  8. Thanks panaghiotisadam

    Re the footer widget problem: My only widget with text has already been deleted - it had no links, just text. And it was visible just fine for days until a day or two ago, which seems like if it had something to do with "unclosed or stray HTML tags', wouldn't it have been a problem immediately?

    Can you guess at why the background is suddenly wonky on the homepage? The default theme background is a grey colour (I have changed it to pale blue because the post content on the homepage was now on the grey background not on the default white as it is for post pages).

    Thanks!

  9. @czthomas
    I have just viewed your blog using both Firefox 3.6.13 and IE8. I do not see anything at all that's odd about the display.

    If that does not work for you, then we need to know which browser and version of it you are using, and how you are connecting to the interent and to wordpress.com.

  10. I checked the sourcecode of your page, and the problem is in your Heart Sisters widget. Open it and save after deleting all this:

    </div>
    <div style="text-align:left;"><span style="color:#000000;"><span style="color:#000000;">
    </span></span></div>
    <p style="text-align:center;"><span style="color:#000000;">
    </span></p>
    </span></p>
  11. After you correct the widget, you'll see that the bg will be normal, and if you add more widgets they'll probably show up at the right place.

  12. http://www.ethicalnag.org

    Hello timethief - I have cleared my cache and cookies now. Still not working.

    "I have just viewed your blog using both Firefox 3.6.13 and IE8. I do not see anything at all that's odd about the display."

    The background issue I'm seeing seems to affect only the homepage (previously white, now seen as a pale blue in both background AND posts/sidebar/footer. I set the pale blue as background because the Duster default background is a darker grey). This is likely why, when the background first went wonky, all text on the homepage (both posts plus sidebar/footer areas) were illegible because my former background was a colourful print. Got rid of that background pronto, even though I'd love to reset that if/when we get this mystery solved.

    The default color for all posts/pages seems to be white. This is good. But now the homepage has NO WHITE - just the pale blue background over everything.

    I have just tried, after clearing cache/cookies, to re-install the calendar widget in the sidebar. Oddly enough, this returned the previous white homepage sections, but the calendar was once again now on the footer, spread wide and weird across the entire page bottom. So I deleted the calendar (again).

    Is there any way we can return the white central section to the homepage? I'm so frustrated that I'm ready to just forget about adding the calendar and links, although it would be a pain not to be able to insert anything more to the sidebar. Do I just have to live with the pale blue over the entire homepage from now on?

    Many thanks!
    Carolyn

  13. Hello panaghiotisadam - I did as you suggested, deleted that code from my Heart Sisters widget. Still not working. Still not able to insert calendar or blogroll widgets into the sidebar.

    My browser is Firefox 3.6.13.

    Thx,
    C.

  14. Nothing to do with your browser. Before replying I checked your sourcecode, saw the wrong HTML, copied the exact code of your widget, used it in my test blog, and got the exact same symptoms.

    But you didn't delete all the wrong code: you've left one closing div tag at the end. Make sure you delete that too, save the widget, clear your cache, and check again.

  15. I can't BELIEVE it! I removed that pesky remaining div tag - - and magically the white text box reappeared on the homepage. With baited breath, I tried re-inserting the Calendar and the Links widgets - and they are now on the sidebar where they belong.

    THANK YOU! I am a complete Luddite when it comes to All Things Techie and, although I'm sure this is easy-peasy for most people, for me these glitches have been pure torture.

    I'm so happy now!!!! I'm going to (very cautiously and with fingers/toes crossed) next going to try to re-insert the original colorful background to replace that boring pale blue.....

    Thanks again.
    Carolyn

  16. quiltguildeffingham
    Member

    Sorry to say i have followed the instructions left by timetheif and have had no luck with it helping my blog in question.

    If anyone has any more suggestions it would be appreciated.

  17. quiltguildeffingham
    Member

    Just fixed the issue, went to the Feb 8th post and removed every single space from between paragraphs, the post looks like hell but at least the page itself looks the way it should!

  18. @lizzyjo: No, timethief was right. It's just that by removing the spaces in the visual editor you also removed some of the bad HTML that was causing the issue.

    As I said to czthomas above (Feb 28, 2011, 5:09 PM), you could have found the culprit post by clicking on each post title and edit that post alone.

    To correct the formatting of the post now, select all in the visual editor, click the Format button, click Paragraph, Update. But first make sure you have enabled the option timethief suggested.

Topic Closed

This topic has been closed to new replies.

About this Topic